Recent

Author Topic: Missing results in a search  (Read 3652 times)

engkin

  • Hero Member
  • *****
  • Posts: 2924
Missing results in a search
« on: August 01, 2021, 07:43:58 pm »
I was looking for a specific forum thread, so I tried the following two words that should've located it quickly in the search box:
engkin jsontools

To my surprise there were no results! I switched to Google and used:
"engkin" "jsontools" site:forum.lazarus.freepascal.org

Again, no results. I eventually found the post but not by using the search box. It is a 2 months old thread and had a recent activity. I tried other search terms, including the title, none of that helped locating the post.

The title is:
JSONTools error while parsing

Are some of the forum posts out of search scope, maybe unintentionally?

winni

  • Hero Member
  • *****
  • Posts: 2661
Re: Missing results in a search
« Reply #1 on: August 01, 2021, 07:52:55 pm »
Put  jsontools in the search box

Put engkin in the user box

There you are

Winni

Fred vS

  • Hero Member
  • *****
  • Posts: 2387
    • StrumPract is the musicians best friend
Re: Missing results in a search
« Reply #2 on: August 01, 2021, 07:54:11 pm »
I was looking for a specific forum thread, so I tried the following two words that should've located it quickly in the search box:
engkin jsontools

To my surprise there were no results! I switched to Google and used:
"engkin" "jsontools" site:forum.lazarus.freepascal.org

Again, no results. I eventually found the post but not by using the search box. It is a 2 months old thread and had a recent activity. I tried other search terms, including the title, none of that helped locating the post.

The title is:
JSONTools error while parsing

Are some of the forum posts out of search scope, maybe unintentionally?

Hello.

Searching for JSONTools error while parsing on Lazarus forum I found this (see picture):
With this topic and [Solved]JSONTools error while parsing

https://forum.lazarus.freepascal.org/index.php/topic,54850.msg407759.html

I use Lazarus 2.0.6 32/64 and FPC 3.2.0 32/64 on Debian 10.2 64 bit, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs
https://gitlab.com/fredvs

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 7391
  • Debugger - SynEdit - and more
    • wiki
Re: Missing results in a search
« Reply #3 on: August 01, 2021, 07:54:30 pm »
All there.

Some quick tests... it *appears" as if: Search only searches the body.

You can go to advanced search, it has a checkbox to include the subject.
If you want to match the person, then you also need advanced search, and fill in the field "by user".

And if you want it a bit faster, set the "message age" to max 300 days.

engkin

  • Hero Member
  • *****
  • Posts: 2924
Re: Missing results in a search
« Reply #4 on: August 01, 2021, 08:13:18 pm »
Let me try again.

....

How do I find that post using engkin and jsontools?


Fred vS

  • Hero Member
  • *****
  • Posts: 2387
    • StrumPract is the musicians best friend
Re: Missing results in a search
« Reply #5 on: August 01, 2021, 08:32:03 pm »
Let me try again.

....

How do I find that post using engkin and jsontools?

Yes, indeed, for good result, minimum 2 words are needed.

If you try with Search:jsontools error and By user:engkin, the post will appear.
I use Lazarus 2.0.6 32/64 and FPC 3.2.0 32/64 on Debian 10.2 64 bit, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs
https://gitlab.com/fredvs

lucamar

  • Hero Member
  • *****
  • Posts: 4219
Re: Missing results in a search
« Reply #6 on: August 01, 2021, 08:38:12 pm »
How do I find that post using engkin and jsontools?

Click either the "Search" item in the top menu or "Advanced search" in the "search" side box. Then ... a couple images are worth two thousand words? ;)

It should find the first post, though for some strange reason it seems it doesn't :o
« Last Edit: August 01, 2021, 08:42:07 pm by lucamar »
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus/FPC 2.0.8/3.0.4 & 2.0.12/3.2.0 - 32/64 bits on:
(K|L|X)Ubuntu 12..18, Windows XP, 7, 10 and various DOSes.

Fred vS

  • Hero Member
  • *****
  • Posts: 2387
    • StrumPract is the musicians best friend
Re: Missing results in a search
« Reply #7 on: August 01, 2021, 08:45:47 pm »
How do I find that post using engkin and jsontools?

Click either the "Search" item in the top menu or "Advanced search" in the "search" side box. Then ... a couple images are worth two thousand words? ;)

It should find the first post, though for some strange reason it seems it doesn't :o

Hum, here with Firefox, it appears only if Search in topic subjects only is enabled.
Strange, no?
I use Lazarus 2.0.6 32/64 and FPC 3.2.0 32/64 on Debian 10.2 64 bit, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs
https://gitlab.com/fredvs

lucamar

  • Hero Member
  • *****
  • Posts: 4219
Re: Missing results in a search
« Reply #8 on: August 01, 2021, 08:50:43 pm »
I had that checked but it returned only one of the answer-posts. I'm using Chromium but it shouldn't matter which browser you use since the search is done by the server. So yeah, strange.
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus/FPC 2.0.8/3.0.4 & 2.0.12/3.2.0 - 32/64 bits on:
(K|L|X)Ubuntu 12..18, Windows XP, 7, 10 and various DOSes.

Fred vS

  • Hero Member
  • *****
  • Posts: 2387
    • StrumPract is the musicians best friend
Re: Missing results in a search
« Reply #9 on: August 01, 2021, 08:58:42 pm »
I had that checked but it returned only one of the answer-posts. I'm using Chromium but it shouldn't matter which browser you use since the search is done by the server. So yeah, strange.

I use Lazarus 2.0.6 32/64 and FPC 3.2.0 32/64 on Debian 10.2 64 bit, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs
https://gitlab.com/fredvs

engkin

  • Hero Member
  • *****
  • Posts: 2924
Re: Missing results in a search
« Reply #10 on: August 01, 2021, 09:17:08 pm »
If you try with Search:jsontools error and By user:engkin, the post will appear.

It did not bring the missing thread, but it did show this one.

Fred vS

  • Hero Member
  • *****
  • Posts: 2387
    • StrumPract is the musicians best friend
Re: Missing results in a search
« Reply #11 on: August 01, 2021, 09:18:01 pm »
It seems to me that if you do a "normal" search, it only search inside the content of the posts.
And if Search in topic subjects only is enable the search is only done in title of posts.

If it is the case, maybe add a warning "Normal search is in content only, not in title."

Or add also a checkbox Search in content only.

My, of course, 0.0000001 cent.

Fre;D
I use Lazarus 2.0.6 32/64 and FPC 3.2.0 32/64 on Debian 10.2 64 bit, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs
https://gitlab.com/fredvs

Fred vS

  • Hero Member
  • *****
  • Posts: 2387
    • StrumPract is the musicians best friend
Re: Missing results in a search
« Reply #12 on: August 01, 2021, 09:29:10 pm »
If you try with Search:jsontools error and By user:engkin, the post will appear.

It did not bring the missing thread, but it did show this one.

If you enable Search in topic subjects only, the missing thread will appear.
It seems that search is exclusive, or in content of post (default) or in title of post.

Not both.
« Last Edit: August 01, 2021, 09:31:31 pm by Fred vS »
I use Lazarus 2.0.6 32/64 and FPC 3.2.0 32/64 on Debian 10.2 64 bit, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs
https://gitlab.com/fredvs

engkin

  • Hero Member
  • *****
  • Posts: 2924
Re: Missing results in a search
« Reply #13 on: August 01, 2021, 09:30:31 pm »
How do I find that post using engkin and jsontools?

Click either the "Search" item in the top menu or "Advanced search" in the "search" side box. Then ... a couple images are worth two thousand words? ;)

It should find the first post, though for some strange reason it seems it doesn't :o

This as you show did bring the missing post. I just don't like the idea that the search results are not complete. Moreover Google search fails to find the missing thread.  %)

engkin

  • Hero Member
  • *****
  • Posts: 2924
Re: Missing results in a search
« Reply #14 on: August 01, 2021, 09:31:37 pm »
If you try with Search:jsontools error and By user:engkin, the post will appear.

It did not bring the missing thread, but it did show this one.

If you enable Search in topic subjects only, the missing thread will appear.

Yes, finally!!

Is this the intended behavior?

 

TinyPortal © 2005-2018