Author Topic: Weird TSQLite3Connection problem  (Read 6812 times)


  • Hero Member
  • *****
  • Posts: 626
[SOLVED] Weird TSQLite3Connection problem
« Reply #15 on: January 31, 2016, 01:32:32 pm »
Your hint about sqlite3.dll version did it.
In my Lazarus folder I had version 3.8.9 and in my stand-alone test folder was a newer version (maybe 64-bit whereas the project is 32-bit).
After replacing the dll the exe file works.
Man, something so simple and yet so hard to find!  :D
Thanks for your time, you really put me on my way again.
« Last Edit: January 31, 2016, 01:37:33 pm by JanRoza »
OS: Windows 10 (64 bit) / Linux Mint (64 bit)
Laz: Lazarus 2.0.12 FPC 3.2.0
       CodeTyphon 7.6 FPC 3.3.1


  • Sr. Member
  • ****
  • Posts: 359
Re: Weird TSQLite3Connection problem
« Reply #16 on: August 04, 2021, 08:04:26 am »
I will try to leave this message for those who also encounter a similar error.

My project used writing and reading datasets. I set the following options for these datasets:
Code: Pascal  [Select][+][-]
  1. qryMasterSelect.Options:= Options + [sqoAutoCommit, sqoKeepOpenOnCommit];

I was getting the same error when I tried to programmatically close the DB connection after connect/disconnect more than 1 time. It didn't depend on the bitness of the library used sqlite3.

As a result, I found a workaround. I began to programmatically create/destroy SQLite3Connection during connection/disconnection, respectively.

Perhaps my experience will be useful to someone.
Win10 LTSC x64/Deb 11 amd64/Darwin Cocoa (Big Sur):
Lazarus x32/x64 2.3(trunk); FPC 3.3.1 (trunk), FireBird 3.0.7

Sorry for my bad English, I'm using translator ;)


TinyPortal © 2005-2018