Recent

Author Topic: 2.2RC1 - assembly level debugging  (Read 1396 times)

440bx

  • Hero Member
  • *****
  • Posts: 2469
2.2RC1 - assembly level debugging
« on: July 31, 2021, 03:32:04 pm »
Hello,

When debugging at the assembly level, the top part of the assembly window seems to always be "empty" (no code shown in it) and when stepping the scrolling seems to occur just one line above the current instruction causing it to disappear once it's been stepped.

What follows is a piece of what the assembly window is showing, the top part of the window having no code:
Code: ASM  [Select][+][-]
  1. 0000000000000000 ......
  2. 0000000000000000 ......
  3. 0000000000000000 ......
  4. 0000000000000000 ......
  5. 0000000000000000 ......
  6. 0000000000000000 ......
  7. 0000000000000000 ......
  8. 0000000000000000 ......
  9. 0000000000000000 ......
  10. 0000000000000000 ......
  11. 0000000000000000 ......
  12. 0000000000000000 ......
  13. 0000000000000000 ......
  14. 0000000000000000 ......
  15. 0000000000000000 ......
  16. 0000000000000000 ......
  17. 0000000000000000 ......
  18. 0000000000000000 ......
  19. 0000000000000000 ......
  20. 000000010000BB29 EB07                     jmp +$07
  21. 000000010000BB2B 488D05D6680100           lea rax,[rip+$000168D6]
  22. 000000010000BB32 90                       nop
  23. 000000010000BB33 488D642428               lea rsp,[rsp+$28]
  24. 000000010000BB38 C3                       ret
  25. 000000010000BB39 0000                     add [rax],al
  26. 000000010000BB3B 0000                     add [rax],al
  27. 000000010000BB3D 0000                     add [rax],al
  28. 000000010000BB3F 005357                   add [rbx+$57],dl
  29. 000000010000BB42 56                       push rsi
  30. 000000010000BB43 4154                     push r12
  31. 000000010000BB45 4155                     push r13
  32. 000000010000BB47 488D6424E0               lea rsp,[rsp-$20]
  33. 000000010000BB4C 4889CB                   mov rbx,rcx
  34. 000000010000BB4F 4889D6                   mov rsi,rdx
  35. 000000010000BB52 4C89C7                   mov rdi,r8
  36.  

Is this behavior due to some configuration setting not being set properly or is this a bug ?

Thank you for your help.
FPC v3.0.4 and Lazarus 1.8.2 on Windows 7 64bit.

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 7405
  • Debugger - SynEdit - and more
    • wiki
Re: 2.2RC1 - assembly level debugging
« Reply #1 on: July 31, 2021, 03:46:54 pm »
Missing feature.
https://wiki.lazarus.freepascal.org/Debugger_Status#Data

You can use the gdb debugger.

440bx

  • Hero Member
  • *****
  • Posts: 2469
Re: 2.2RC1 - assembly level debugging
« Reply #2 on: July 31, 2021, 04:05:59 pm »
No problem.

I'm going to stick with FpDebug for the time being (FpDebug is the reason I installed 2.2RC1)

I wanted to try the new debugger.
FPC v3.0.4 and Lazarus 1.8.2 on Windows 7 64bit.

 

TinyPortal © 2005-2018