Forum > Options

[SOLVED] Importing Color settings from v1.8.2 to 2.2RC1

(1/2) > >>


I have been trying, very unsuccessfully, to import the color settings from Lazarus v1.8.2 into Lazarus 2.2 RC1.

On my current installation (v1.8.2) I went to Tools->Options->Editor->Display->Colors, clicked on the "export" icon (little disk) and exported those settings into a .xml file.

I've tried to "feed" that .xml file to v2.2 RC1 every which way I could think of to no avail. No matter what I do, I don't get the colors I had in v1.8.2.  I always get the "default" colors.

My question is probably obvious by now: how do I get v2.2 RC1 to use the colors I have set in v1.8.2 ?

Thank for your help.


--- Quote --- copying them into a folder called "userschemes" in the primary-config-path.
--- End quote ---

Or you can copy the entire EditorOptions.xml - if the other settings are ok for you.
(afaik it has no path related settings, so it can be copied)

I must be doing something wrong but, I cannot figure out what it is.

I currently have a file named "LazarusExportedSettings.xml" in the directory "C:\Users\Private\AppData\Local\lazarus\userschemes", that didn't work.

since that didn't work, I made a copy of that file and named it "ColorOcean.xml" replacing the original "ColorOcean.xml" in the directory "C:\lazrc1\ide" which is where I installed v2.2 RC1. 

That didn't work either, when I selected the "Color Ocean" scheme, I got the original Ocean colors instead of the colors in my .xml file (where it got the original colors from, I have no idea)

Since that didn't work, I tried replacing "ColorDefault.xml" with my file, long story longer, that didn't work either.

I don't know what else to try.  Any ideas ?

Ok, I have no idea if you can "replace" one of the build ins. (that was never planed, nor tested, and it may not even give a warning / if you find details on it, and its silently ignored, the file a bug that a warning should be given)

I just downloaded one of the schemes from the wiki.
And that shows up, with its own name, and that I can select.

Note that its not the filename, but the name inside the xml.


--- Quote from: Martin_fr on July 31, 2021, 11:41:33 am ---I just downloaded one of the schemes from the wiki.
And that shows up, with its own name, and that I can select.

--- End quote ---
I'll give that a try. if that works, I'll try to figure out what the difference is between the downloaded one and mine.

Thank you.  At least I have something else to try. :)


[0] Message Index

[#] Next page

Go to full version