Recent

Author Topic: [Fixed] Legend settings issues in ChartEditor demo  (Read 1876 times)

Muso

  • Full Member
  • ***
  • Posts: 228
[Fixed] Legend settings issues in ChartEditor demo
« on: July 31, 2021, 05:22:12 am »
I see a regression in the chart editor dome:

- start the demo and double-click on the legend
- in the appearing dialog the setting of the position has no longer an effect (I am pretty sure this worked a while a go)

There is also another issue:
- double-click on the legend
- in the appearing dialog the setting of the Margins Y has no effect.
- change the y Margins nevertheless e.g. to 25
- reopen the legend dialog ans you can see that your change was ignored - y Margins is at 4

For x Margins, it works however fine.

Can anybody reproduce this?

I use Lazarus 2.3.0 r65499 FPC 3.2.2 x86_64-win64-win32/win64
« Last Edit: July 31, 2021, 04:57:41 pm by Muso »

wp

  • Hero Member
  • *****
  • Posts: 8749
Re: Legend settings issues in ChartEditor demo
« Reply #1 on: July 31, 2021, 12:43:45 pm »
Fixed.
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

Muso

  • Full Member
  • ***
  • Posts: 228
Re: Legend settings issues in ChartEditor demo
« Reply #2 on: July 31, 2021, 04:57:30 pm »
Fixed.

Many thanks!

The SVN to Git change broke my Lazarus system a bit, but I could grab the changes from the Github mirror:
https://github.com/fpc/Lazarus/commit/ca18b6796a5c0615fef2bdda29e0af5f5d55189f.diff

And can report that the issues have been fixed.

 

TinyPortal © 2005-2018