Forum > macOS / Mac OS X

MacOS Lazarus Problems - New to Lazarus

(1/3) > >>

c_knowles4834:
Hello all,

I was wondering if anyone has run into this issue that I am facing at the moment.  I keep getting this error message when trying to run simple 'HelloWorld' programs or any programs at all:

Compile package LCL 2.2.0.1: Exit code 1, Errors: 1
lcltype.pp(18,42) Fatal: Invalid PPU-File entry: 87

Being so new to Lazarus and programming in object pascal, I really have no idea how to solve this problem.  Any help would be appreciated very much. 

Just FYI, I just downloaded Lazarus with the files below and barely got through the configuration process:

Lazarus 2.2.0RC1-x86_64-macosx.pkg
fpc-src-3.2.0.2-laz.pkg
fpc-3.2.0.intel-mcosx.dmg
(Xcode command-line tools were also installed.)

Thanks!



trev:
First off, you're installing a pre-release version (Lazarus 2.2. Release Candidate 1) which has a few bugs.

However, it does successfully install on both Intel and aarch64 Macs (I've trested it on Big Sur on both architectures).

1. What version of macOS are you using?
2. What architecture? Intel or aarch64 (M1) ?
3. Did you install the Xcode command line tools first?
4. Did you install FPC and its source before Lazarus?

c_knowles4834:
1. What version of macOS are you using?

Big Sur 11.5

2. What architecture? Intel or aarch64 (M1) ?

I believe Intel and I am assuming you are asking about my CPU. However, I am not sure what you mean by architecture. Where would I go to find that information?

3. Did you install the Xcode command line tools first?

Yes, I followed the instructions on the wiki for the MacOS download.

4. Did you install FPC and its source before Lazarus?

Yes, I made sure to install all the needed files in their designated order.

trev:
Architecture: Intel or Apple Silicon M1 (aarch64).

If you followed the Wiki instructions that's really inexplicable because I have installed the same release candidate on Big Sur successfully on both a 2018 Intel Mac mini and a 2020 M1 Mac mini.

I'm not really sure what to suggest...

Can you successfully compile a trivial free pascal program? For example test.pas containing just:


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---Program test; Begin  WriteLn('Hello World!');End.
Compile in a Terminal with:

fpc test.pas

and then execute with:

./test

If that works, then I'd try reinstalling Lazarus.

Jonas Maebe:
Isn't the issue that you installed FPC 3.2.0 rather than 3.2.2?

Navigation

[0] Message Index

[#] Next page

Go to full version