Recent

Author Topic: libqt5pas | how to get the lastest  (Read 6202 times)

cpalx

  • Hero Member
  • *****
  • Posts: 692
libqt5pas | how to get the lastest
« on: July 23, 2021, 08:36:09 pm »
Hello,

How can i get the lastest libqt5pas?

where to download?
if i have to compile, how to compiled?

winni

  • Hero Member
  • *****
  • Posts: 2666
Re: libqt5pas | how to get the lastest
« Reply #1 on: July 23, 2021, 09:33:29 pm »
Hi!

The latest version I know is from April 2021.

rpm, deb and source available:

https://github.com/davidbannon/libqt5pas/releases/tag/v1.2.9

Winni

dbannon

  • Hero Member
  • *****
  • Posts: 1537
    • tomboy-ng, a rewrite of the classic Tomboy
Re: libqt5pas | how to get the lastest
« Reply #2 on: July 24, 2021, 02:20:22 am »
You probably don't need that version that winni mentioned. Most Linux (and we assume you are using Linux) distros that have suitable Qt5 also have a suitable libqt5pas1 package.

Maybe if you outline your use case, we could be a bit more forthcoming.

Davo
Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

cpalx

  • Hero Member
  • *****
  • Posts: 692
Re: libqt5pas | how to get the lastest
« Reply #3 on: July 24, 2021, 06:20:15 pm »
@dbannon, yes i have instaleld, but i need the last one.
I have problems to compile lazarus 2.2RC1 with QT5

cpalx

  • Hero Member
  • *****
  • Posts: 692
Re: libqt5pas | how to get the lastest
« Reply #4 on: July 24, 2021, 06:24:22 pm »
@Winni, works perfectly

but I would like to compile by my self.

Please any help?

dbannon

  • Hero Member
  • *****
  • Posts: 1537
    • tomboy-ng, a rewrite of the classic Tomboy
Re: libqt5pas | how to get the lastest
« Reply #5 on: July 25, 2021, 02:26:26 am »
If you look in the Lazarus source, lcl->interfaces->qt5 there is a directory in there with everything ypu need, including instructions on building.

I am a bit surprised that you say you must have that newer version to use the release candidate. Can you tell us what OS you are using ?  The only currently supported (mainstream) one that might be an issue is U18.04. U16.04 does not have a usable QT. U18.04 does need a new libqt5pas but should not need the 'newest' one on that github page, that newest incorporated some changes Zelijko introduced, and then reversed, that supported a screenreader.

Davo
Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

cpalx

  • Hero Member
  • *****
  • Posts: 692
Re: libqt5pas | how to get the lastest
« Reply #6 on: July 26, 2021, 12:54:42 am »
i am using KDE neon, nut the same problem is in Kubuntu 20.04.

cpalx

  • Hero Member
  • *****
  • Posts: 692
Re: libqt5pas | how to get the lastest
« Reply #7 on: July 26, 2021, 01:30:10 am »
Here is Error with the old libqt5pas

dbannon

  • Hero Member
  • *****
  • Posts: 1537
    • tomboy-ng, a rewrite of the classic Tomboy
Re: libqt5pas | how to get the lastest
« Reply #8 on: July 26, 2021, 02:16:42 am »
That error is saying it cannot find any libqt5pas, did you check that the distro package one is installed ?

Its not installed automatically when you install Lazarus because Lazarus is not sure you are going to use Qt5.  So, its a manual install.

sudo apt install libqt5pas on an Ubuntu like box.

(there is no reason why you should not make your own and use it but it becomes a nuisance if you want to distribute the app to other users.)

Davo
Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

zeljko

  • Hero Member
  • *****
  • Posts: 1188
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: libqt5pas | how to get the lastest
« Reply #9 on: July 26, 2021, 08:56:25 am »
For building Qt5 apps with Lazarus you must install libqt5pas-dev package.

dbannon

  • Hero Member
  • *****
  • Posts: 1537
    • tomboy-ng, a rewrite of the classic Tomboy
Re: libqt5pas | how to get the lastest
« Reply #10 on: July 26, 2021, 12:59:25 pm »
Yeah, of course, I meant to say -dev in above post. Sigh ...

Code: [Select]
sudo apt install libqt5pas-dev
It will pull in libqt5pas and any more of the Qt5 libraries needed.

Davo
Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

 

TinyPortal © 2005-2018