Recent

Author Topic: [Fixed] Laz 2.2 ParentColor issue for new labels  (Read 3113 times)

Muso

  • Full Member
  • ***
  • Posts: 228
[Fixed] Laz 2.2 ParentColor issue for new labels
« on: July 21, 2021, 04:34:10 am »
I have an issue with the default settings of labels:

- add a new group box (or radio/check group) to a form

result: the property "ParentColor " is at "False".

The IDE tells me:
"ParentColor determines if the control should use the Color from the Parent control, when enabled. The default value is True."
So that means that the default setting for new labels for ParentColor is not the actual default, or the IDE info is wrong.

I am using Lazarus 2.3.0 r65474 FPC 3.2.2 x86_64-win64-win32/win64 but that means the issue is also in Laz 2.2.

Should I open a bug report?
« Last Edit: July 21, 2021, 10:12:04 pm by Muso »

dsiders

  • Hero Member
  • *****
  • Posts: 509
Re: Laz 2.2 ParentColor issue for new labels
« Reply #1 on: July 21, 2021, 05:14:11 am »
I have an issue with the default settings of labels:

- add a new group box (or radio/check group) to a form

result: the property "ParentColor " is at "False".

The IDE tells me:
"ParentColor determines if the control should use the Color from the Parent control, when enabled. The default value is True."
So that means that the default setting for new labels for ParentColor is not the actual default, or the IDE info is wrong.

I am using Lazarus 2.3.0 r65474 FPC 3.2.2 x86_64-win64-win32/win64 but that means the issue is also in Laz 2.2.

Should I open a bug report?

Noted. Looking into it now...
Lazarus 2.0.12, 2.2.0-RC1, 2.3.0 (Git) / FPC 3.2.0, 3.2.2 / x86-win64 / Windows 8.1

dsiders

  • Hero Member
  • *****
  • Posts: 509
Re: Laz 2.2 ParentColor issue for new labels
« Reply #2 on: July 21, 2021, 06:35:36 am »
I have an issue with the default settings of labels:

- add a new group box (or radio/check group) to a form

result: the property "ParentColor " is at "False".

The IDE tells me:
"ParentColor determines if the control should use the Color from the Parent control, when enabled. The default value is True."
So that means that the default setting for new labels for ParentColor is not the actual default, or the IDE info is wrong.

I am using Lazarus 2.3.0 r65474 FPC 3.2.2 x86_64-win64-win32/win64 but that means the issue is also in Laz 2.2.

Should I open a bug report?

You're seeing the topic description from the ancestor class. There are some properties that get republished with changed default values, like: AutoSize, Color, ParentColor, TabStop, BorderStyle, etc. They are still linked to the inherited topic.

They're being addressed, and will be fixed in trunk soon. They will be in the next release candidate if the changes make merge window.

Thanks for pointing this out.
Lazarus 2.0.12, 2.2.0-RC1, 2.3.0 (Git) / FPC 3.2.0, 3.2.2 / x86-win64 / Windows 8.1

Muso

  • Full Member
  • ***
  • Posts: 228
Re: Laz 2.2 ParentColor issue for new labels
« Reply #3 on: July 21, 2021, 07:30:06 pm »
They're being addressed, and will be fixed in trunk soon.

many thanks! Please tell me when you made the fix that I could test it.

dsiders

  • Hero Member
  • *****
  • Posts: 509
Re: Laz 2.2 ParentColor issue for new labels
« Reply #4 on: July 21, 2021, 09:35:25 pm »
They're being addressed, and will be fixed in trunk soon.
many thanks! Please tell me when you made the fix that I could test it.

Updates posted in r65481. Please try again. If you find any other documentation issues, please post to Miscellaneous > Documentation (Maintaining) or to Mantis if you prefer.
Lazarus 2.0.12, 2.2.0-RC1, 2.3.0 (Git) / FPC 3.2.0, 3.2.2 / x86-win64 / Windows 8.1

Muso

  • Full Member
  • ***
  • Posts: 228
Re: Laz 2.2 ParentColor issue for new labels
« Reply #5 on: July 21, 2021, 10:11:51 pm »
Updates posted in r65481. Please try again.

Many thanks. This commit is huge.

I tested and can confirm the issue is fixed. I hope it will be merged for Laz 2.2.

 

TinyPortal © 2005-2018