Recent

Author Topic: IBX won't let Lazarus start (with Firebird 4 installed)  (Read 1773 times)

sydenis

  • New Member
  • *
  • Posts: 31
IBX won't let Lazarus start (with Firebird 4 installed)
« on: July 20, 2021, 12:31:46 pm »
Ubuntu 20.04 + Firebird 4.0.0.496 + IBX 2.4.1

I have downloaded and installed Firebird tar.gz from official site.
After this I install IBX package and restart Lazarus IDE.
Lazarus can't start with the error: Object reference is Nil.
What else should I do or install for the Lazarus to start?
« Last Edit: July 20, 2021, 12:33:56 pm by sydenis »

sydenis

  • New Member
  • *
  • Posts: 31
Re: IBX won't let Lazarus start (with Firebird 4 installed)
« Reply #1 on: September 23, 2021, 09:11:59 am »
The problem is that if Firebird is not installed from the repository, then its libraries are not registered in the OS.
Therefore, ibx does not see them.
For example, in ubuntu, the problem is solved like this:
- specifying the path (/opt/firebird/lib/) to the fb libraries in /etc/ld.so. conf
- update the library cache -  sudo ldconfig

But it seems to me that ibx should also be more accurate.
It shouldn't kill the entire IDE. For example, it should still be possible to uninstall ibx...
« Last Edit: September 23, 2021, 09:21:05 am by sydenis »

GetMem

  • Hero Member
  • *****
  • Posts: 3492
Re: IBX won't let Lazarus start (with Firebird 4 installed)
« Reply #2 on: September 23, 2021, 10:24:33 am »
Hi sydenis,

It was discussed before. Please see the following thread:
https://forum.lazarus.freepascal.org/index.php/topic,54287.0.html

sydenis

  • New Member
  • *
  • Posts: 31
Re: IBX won't let Lazarus start (with Firebird 4 installed)
« Reply #3 on: September 23, 2021, 10:38:30 am »
GetMem thank you for pointing it out.
I hope that Tony will be able to do everything that he has planned.
Thank you in advance.

tonyw

  • Full Member
  • ***
  • Posts: 229
    • MWA Software
Re: IBX won't let Lazarus start (with Firebird 4 installed)
« Reply #4 on: September 23, 2021, 02:44:26 pm »
The IBX snapshot available from http://www.mwasoftware.co.uk/svn-repository should no longer kill the IDE if there is an exception when loading the firebird library.

If you have installed a version of Firebird (e.g. in /opt/firebird) without registering the library, you can always start Lazarus with the following environment variables:

export FIREBIRD=/opt/firebird
export LD_LIBRARY_PATH=$FIREBIRD/lib

When testing IBX, I have several versions of Firebird running at the same time, but listening on different ports. Setting the above either before loading the IDE, or as program execution options, allows me to select the version of Firebird used for the test - helps test out new versions without having to have several different computers to test on.

sydenis

  • New Member
  • *
  • Posts: 31
Re: IBX won't let Lazarus start (with Firebird 4 installed)
« Reply #5 on: September 23, 2021, 04:51:48 pm »
Tony, thank you. I will test it now

devEric69

  • Hero Member
  • *****
  • Posts: 614
use: Linux 64 bits (Ubuntu 20.04 LTS).
Lazarus version: 2.0.4 (svn revision: 62502M) compiled with fpc 3.0.4 - fpDebug \ Dwarf3.

 

TinyPortal © 2005-2018