Forum > Other

Building Lazarus 2.0.12 with FreePascal 3.2.2 fails under FreeBSD


During the build, it crashes with telling there is no /usr/local/local/lazarus. Can be solved by
--- Code: Bash  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---ln -s /usr/local /usr/local/localbut before this, it worked. (With FreePascal 3.2.0 and Lazarus 2.0.10.)

Please check if the -Fl statement in the fpc.cfg is ok. is often updated without testing all targets. It might be some sideeffect (running the scripts and commands under bash might also help)


--- Code: ----Fl/usr/local/lib
--- End code ---
These are the only lines with -Fl in my system's /etc/fpc.cfg. I did not alter it manually.

I think that is the only place where Free Pascal uses that.  Not entirely (in theory there could be hardcoded paths in t_bsd, but I doubt it).

So my first guess would be that is on the lazarus side.


[0] Message Index

Go to full version