Forum > Other

Building Lazarus 2.0.12 with FreePascal 3.2.2 fails under OpenBSD

(1/2) > >>

TCH:
After installing FPC 3.2.2 (with sources) i try to gmake clean bigide and it crashes half the way
--- Code: ---(3104) Compiling iphttpbroker.pas
Fatal: (10022) Can't find unit cNetDB used by netdb
Fatal: (1018) Compilation aborted
gmake[2]: *** [Makefile:3234: turbopoweripro.ppu] Error 1
gmake[2]: Leaving directory '/tmp/lazarus/components/turbopower_ipro'
gmake[1]: *** [Makefile:1788: bigide] Error 2
gmake[1]: Leaving directory '/tmp/lazarus/components'
gmake: *** [Makefile:3673: bigidecomponents] Error 2
--- End code ---
It's OpenBSD 6.8 AMD64.

Before this, i could compile Lazarus 2.0.10 with FreePascal 3.2.0 and everything worked. I did not change anything in the system, aside from FreePascal and Lazarus.

DonAlfredo:
This might be a regression. I encountered the same problem. It is solved by using the included patch.

TCH:
Thanks for the help and the patch. Now i know where to look next time if i encounter a similar error. (BTW, NetBSD is still missing from that list, or is that unsupported?)

marcov:
In general unit are often only enabled for the platforms they are validated for. This is often a problem with *BSD.

TCH:
Would not be better to enable for all and let the problems happen with the unit itself on the specific platforms? At least then it will be tested and hopefully fixed.

Navigation

[0] Message Index

[#] Next page

Go to full version