Forum > Options

How tell auto-completion to insert spaces around :=

<< < (2/2)

lucamar:
Strange; it works as it should here. For example, if you have:

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---var  Something: Integer;begin |end;an use autocompletion to insert "Something" at the caret's position, it adds the ":=" with the proper spaces around. But, of course, only if you have "Add assignment operator" checked in "Identifier completion" (right below "Space" in CodeTools options).

ssawgift:
After some tries, it turned out that the codetools->Space setting works for auto-completion. I did not check two checkboxes for 'Symbol'.

Navigation

[0] Message Index

[*] Previous page

Go to full version