Forum > Linux

Lazarus 2.0.12 on Ubuntu 21.10 install error Dependency not satisfiable

(1/8) > >>

corradoventu:
Lazarus 2.0.12 on Ubuntu 21.10 install error Dependency not satisfiable fpc-laz(=3.2.0)
1st i installed Lazarus from Ubuntu repository install successful but does not work. removed and downloaded from https://sourceforge.net/projects/lazarus/
try to install with ubuntu software installed: error for  missing dependency.
retry install with gdebi: still Dependency not satisfiable.
see attachment.
thanks for suggestions

lucamar:
Install fpc (and fpc-src) v3.2.0 before trying to install Lazarus. Lazarus 2.0.12 needs fpc 3.2.0 but AFAICT it's not yet in the standard package repos.

corradoventu:
Ok, will use Lazarus on my Ubuntu 20.04 partition and wait for 21.10
thanks

lucamar:
Why? You just have to download the three .deb from sourceforge and install them in order: first fpc-laz, then fpc-src and last lazarus-project.

VTwin:
Installation of the three deb packages, as lucamar says, is very easy. There is no point in waiting until it shows up in the Ubuntu repository, which is unlikely to ever be up to date.

You may find some complex instructions for installing on Linux, but it is not really hard. You may need to install libgtk2.0-dev as well though.

Something like:


--- Code: ---sudo apt-get install libgtk2.0-dev
sudo dpkg -i *.deb
--- End code ---

should work. This assumes the 3 deb files are in the current directory using the terminal. You can use three calls to dpkg in order, but this call should do the same.

Navigation

[0] Message Index

[#] Next page

Go to full version