Forum > Third party

[Solved] Problem with IBX "SQL monitor"



I'm trying to integrate an IBX "SQL monitor" (TIBSQLMonitor component) into an IBX 2.3.2. embedded application. I've studied the "Integrated Monitoring Example" application named IntegratedMonitor. It works very well.

I've tried to port it into an embedded application, on the same development workstation. But, I can't get it to work properly. I believe there are 2 probable causes for "SQL monitor" not working in my embedded application:
a) I've not studied enough its source code to port it in my application properly;
b) there is an incompatibility with my embedded configuration; In the latter case, this is what I've noticed:
• When it works with IntegratedMonitor software, here are the loaded libraries (using a centralized server Firebird 3.0):
• When it doesn't work with MyAppli, here are the loaded libraries (using a tar.gz unzipped embedded Firebird 3.0.5, localized in /home):
/home/.../Myappli/config/firebird/3.0/intl/fbintl                              (<== no more
The library isn't loaded by embedded MyAppli: does it matter? Anything else incoherent?


My "ReaderThread while" loop was reading fine, but could never call receiveMessage, due to the precondition clauses that were always shunting the code leading to writeSQLData (said another way, my FTraceFlags set was always equal to [] leading towards Exit;).

So, "SQL monitor" works with an embedded database too. And a library may not be terminated by *.so extension: strange, but it can be like that.


[0] Message Index

Go to full version