Forum > Editor

[SOLVED] keystrokes duplicated


borland convert:
just installed the latest Lazarus and Freepascal.
Checksum checked okay.
Using Ubuntu 20.04 with all updates.

When start typing in the editor, every keystroke is duplicated

e.g. // this is a comment     becomes
      ////  tthhiiss  aa  ccoommmmeenntt

Any way to fix this?

@borland convert
Please read the following thread:,39213.0.html
and this wikipedia article:

Gustavo 'Gus' Carreno:
Hey All,

This is really strange!!!

I haven't had this problem in years and I have been updating my Ubuntu every 6 months.
I'm now on 20.10 and waiting for the release of 21.04.
But I did completely forget how I solved this issue when I had it :(

But if had such a problem, now, the new arrangement of the Settings no longer has "System Settings->Preferences->Input Method"

I've had a good search and I can't find "Input Method" anywhere else :(

Let's hope that methods 3, 4 or 5 on the Wiki page can solve this problem.



[0] Message Index

Go to full version