Recent

Author Topic: Reference to object set to Nil after installation of IBX Components  (Read 352 times)

eenplus

  • New Member
  • *
  • Posts: 11
Hallo, I've installed the latest version of the IBX components in two Lazarus versions. One on Mac High Sierra 10.13.16 ( native ) and on Windows 10 in Parallels.
After each install via the Online Package Manager and rebuilding and restarting the IDE , Lazarus quits with a 'Reference set to object is Nil' . Afterwards I need
to reinstall Lazarus.

Is this a known issue ?

Tia.

/Dirk 

GetMem

  • Hero Member
  • *****
  • Posts: 4017
Re: Reference to object set to Nil after installation of IBX Components
« Reply #1 on: April 22, 2021, 08:38:12 pm »
@eenplus
Quote
Hallo, I've installed the latest version of the IBX components in two Lazarus versions. One on Mac High Sierra 10.13.16 ( native ) and on Windows 10 in Parallels.
After each install via the Online Package Manager and rebuilding and restarting the IDE , Lazarus quits with a 'Reference set to object is Nil' . Afterwards I need
to reinstall Lazarus.

Is this a known issue ?
First of all you don't have to reinstall Lazarus, you always have a backup of the binary in the installation folder(see attached screenshot). Delete the current executable, then rename lazarus.old to lazarus.
Secondly I don't think this issue is related to OPM, please try to install IBX by opening the lpk file. Does the same error occurs?

eenplus

  • New Member
  • *
  • Posts: 11
Re: Reference to object set to Nil after installation of IBX Components
« Reply #2 on: April 22, 2021, 09:55:05 pm »
Hallo, as per suggestion of GetMem I did. Unfortunately same issue. I enclose an image of the error at startup. Rgds.

GetMem

  • Hero Member
  • *****
  • Posts: 4017
Re: Reference to object set to Nil after installation of IBX Components
« Reply #3 on: April 23, 2021, 06:51:24 am »
Quote
Hallo, as per suggestion of GetMem I did. Unfortunately same issue. I enclose an image of the error at startup. Rgds.

Tested with:
Lazarus: 2.0.12/Trunk
FPC:  3.2.0
OS: Windows 10

IBX works fine here.

eenplus

  • New Member
  • *
  • Posts: 11
Still suffering with installation of IBX controls .... whatever way I install the componenten, each installation ends up with Lazarus not being able anymore to start. Always "Object reference is Nil."

And I can start over to rename the old Lazarus.app etc. to get things going.

Is there a possibility to start Lazarus in some kind of 'safe mode' , of debug mode ?

« Last Edit: May 11, 2021, 04:34:51 pm by eenplus »

 

TinyPortal © 2005-2018