Forum > Editor

Tabs in Source Editor

(1/5) > >>

I am using Lazarus Trunk (64999) on my BigSur M1. Whenever I press the 'tab' key in the source editor, the cursor position changes to the first line of the source code. I removed the configuration folder ~/.lazarus and rebuilt Lazarus from Source, and I have the same behavior. I tried different preferences in the Preferences/General/TabAndIndent menu which did not resolve anything. Is this issue unique to me, and if not is there a work around? It is 100% reliable, pressing tab anywhere in any project's source code shifts the cursor to the start of the file.

I hadn't noticed (I guess I'm used to using spaces) but you're right - same issue in r64891. Best create a Bug Report over in the BugTracker.

If you go to tools >Options > Editor > Keymap:

Using e.g. Search and capture key: What does it get if you capture the tab key?

What does it show, to which command it is assigned?

Lazarus > Preferences > Editor -> Key mappings

See pic.

That (the layout in the image) is correct.
And I take it, the "grab key" did recognize tab as tab?

I suspect that there is some key handling before the editor gets the tab.
But lets make  sure of a couple of things.

1) The editor does not believe to be in syncro or template mode.
Remove the "tab" for each of the 2 groups (first for one then for the other group).
The 2 syncro as group, and the 2 template as group.

2) With tab assigned again, start syncro edit (select text with duplicate words, and press ctrl-J). There should be highlighted fields for the duplicate words. Tab should go between the fields.


[0] Message Index

[#] Next page

Go to full version