Forum > Russian

sparta в 2.0.12

(1/3) > >>

sydenis:
Подскажите как ставить sparta (редактор форм в стиле delphi)?
В прошлых релизах, помнится, просто выбирал нужный пакет в "Поставить/Удалить пакеты",
а сейчас так не выходит - идёт ругань на chmhelp и среда не перекомпилируется.

В яндексе пишут, что такая проблема всплывала уже пару лет назад, но тогда же и пофиксили.
В чём теперь дело? Кто-нибудь уже прикручивал спарту в этом релизе?

И ещё вопрос: в Установке пакетов вылазит 4 пакета, начинающиеся со sparta_*
Они все нужны? Или есть какой-то достаточный минимум?

sydenis:
Может кому поможет:
1. В пакетах спарты и chmhelppkg есть конфликт типов. Старослужащие рекомендуют удалить chmhelppkg.
Я попробовал - спарта встала нормально. Неделя - полёт нормальный.
2. Из всего зоопарка пакетов спарты достаточно поставить sparta_dockedformeditor. Всё работает.
Про остальные - читал заметки (2016 года) автора спарты, где он пишет, что всё остальное это его смелые фантазии и пока нет времени на реализацию.

avk:
Если я помню правильно, чтобы sparta_dockedformeditor установился без проблем, достаточно удалить зависимость sparta_generics в пакете sparta_mdi.

Alextp:
Sparta docked forms editor не нужен, в Лаз транке будет вместо него dockedFormsEditor пакет.

Michl:
Just translated per Bing.

Just a note: All Sparta packages are now marked as deprecated. In Laz Trunk, you can use DockedFormEditor. In 2.0.x, I add it as zip.

See also: https://forum.lazarus.freepascal.org/index.php?topic=53314.0


Только что переведено на Bing.

Только примечание: все пакеты Sparta теперь помечены как устаревшие. В Laz Trunk вы можете использовать DockedFormEditor. В версии 2.0.x я добавляю его как zip.

См. Также: https://forum.lazarus.freepascal.org/index.php?topic=53314.0

Navigation

[0] Message Index

[#] Next page

Go to full version