Forum > QT

[SOLVED] QT5 with latest Lazarus has undefined references

<< < (3/8) > >>

MarkMLl:
The basic  qmake -query  works on a more mature system (both Debian).

Both systems obviously have libqt5pas-dev, the more mature system also has libqt5opengl5-dev:amd64 qtbase5-dev:amd64 qtbase5-dev-tools qttools5-dev-tools.

dpkg -S /usr/bin/qmake  says it's from qtchooser, but that's definitely not something I've installed manually. I log package installation fairly carefully but what it doesn't show is the actual command like and the "top level" package that pulled other stuff in.

MarkMLl

dbannon:
The way I understood it, you only needed the new libqt5pas libraries if you are using the specific features zeljko has just added. Thats what happened in the past and is workable. However, that is not the case now and I am afraid things appear to be seriously broken.

I have just pulled down Lazarus trunk and tried to build my app on a U20.04 machine with std repo versions of libqt5pas and it fails. Prior to the recent accessibility additions it works fine. This means that anyone using trunk now must use the libraries for my github if they use Qt5 apps, end users as well as developers. 

I am quite sure that was not the intended outcome and suggest it needs to be reversed.

Davo

MarkMLl:
I'm watching with interest. In the interim do you have any suggestion what packages are the minimum required for building? I think that would be of interest to anybody who occasionally rebuilds lazarus-trunk since by and large we'd expect to have the development tools and libraries applicable to our OS etc. available as a prerequisite.

MarkMLl

dbannon:

--- Quote from: MarkMLl on April 06, 2021, 01:43:45 pm ---"Replace" would be more appropriate, ...

--- End quote ---

Yes, its definitely a replace.


--- Quote from: MarkMLl ---..... with the numbering rationale being in https://github.com/davidbannon/libqt5pas/blob/master/README.md

If my understanding is correct Debian's 2.6 corresponds to his 1.2.6 etc.

--- End quote ---

Yes, sort of.  The main library is libqt5pas1 and version 2.6 but the dev package drops the '1', Debian versioning is a very arcane art.

Anyway, its been called 1.2.6 for a long time while zeljko has been making incremental changes.  All those changes, up to now, have been backwards compatible.  The distros have been using an incredibly ugly version number like 1.2.6~beta-6build1 and that '~' is an absolute menace. Zeljko agreed to call it 1.2.8 last time around to get rid of the '~' and to ensure a higher version number than 1.2.6something.  To avoid auto updates from breaking things.

But the point is, until this recent change, only quite old distros eg U18.04 and friends, needed to worry about it.  Suddenly, we have a backwards compatibility issue !


--- Quote from: MarkMLl ---Building from lazarus/trunk sources looks like a problem on a comparatively clean system,

--- End quote ---

Its not hard, slow, you will need qmake and libqt5x11extras-dev. Probably will have everything else.  But our end users ?  Thats a very different situation !

Don't worry about the qmake -query, just proceed to qmake qt=qt5. Or use mine from the github repo, no back doors, I promise !

Davo

dbannon:

--- Quote from: MarkMLl on April 06, 2021, 03:20:22 pm ---I'm watching with interest. In the interim do you have any suggestion what packages are the minimum required for building? I think that would be of interest to anybody who occasionally rebuilds lazarus-trunk since by and large we'd expect to have the development tools and libraries applicable to our OS etc. available as a prerequisite.

MarkMLl

--- End quote ---

As I mentioned above, qmake and libqt5x11extras-dev. Probably will have everything else.

But if this change makes it through to release Lazarus, in say, 2.1.0, QT5 will be useless for any app thats going to be distributed until the distros catch up. And that is a matter of several years. U20.04 is probably good until 2024 ....

Debian Testing is in a feature freeze mode now, wonder if we should be pushing to get this "new and improved" lib into it ?  Will have to test to see it does not break Lazarus 2.0.12 for example. Sigh ...

Davo

Davo

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version