Forum > Other OS

WriteLn and DOSBox

<< < (5/5)

Just adding some info to fully resolve/explain this issue.

The WriteLn issue is (almost certainly) not due to a bug in FPC; it is due to a bug in DOSBox.

To test, I used the FPC installer for DOS. There was no special reason to use the FPC installer; I only used it because I noticed the strange display issues when I had previously tried running it under DOSBox.

The installer displayed fine on:
    * FreeDOS 1.2 running under QEMU
    * FreeDOS 1.3 running under Bochs 2.7
    * DOSBox-X v0.83.22

The installer did not display fine on DOSBox (v0.74-3). If interested, see the attachment, 'install.png' which shows another example of what other people have described.

Interestingly, there seems to be a deeper issue with DOSBox which may be related to the screen corruption issue. In DOSBox, when INSTALL.EXE was run, it could not find the INSTALL.DAT file. (The error is shown in the attachment.) Both files reside in the same directory. The exact same directory was used with DOSBox-X and it worked fine.


AFAIK FreeDOS uses some code from DOSbox so maybe that's why both have the same behavior.


[0] Message Index

[*] Previous page

Go to full version