Forum > Debugger

Debugger problems after update to Lazarus-2.0.12-fpc-3.2.0-win64

(1/2) > >>

Hello, everybody.

The Situation:

--- Code: ---OS                 Microsoft Windows 10 Pro
Version                 10.0.19042 Build 19042
Prozessor         AMD Ryzen 5 5600X 6-Core Processor, 3701 MHz, 6 Kern(e), 12 logische(r) Prozessor(en)
BIOS-Version/-Dae American Megatrends Inc. 3001, 04.12.2020
SMBIOS-Version         3.3
BIOS-Modus         UEFI
BaseBoard-Manufacturer ASUSTeK COMPUTER INC.
BaseBoard-Product PRIME X570-PRO
BaseBoard-Version Rev X.0x

--- End code ---

The Problem:

I'm "training" here with a small demo application called "guitarclub" that I downloaded once ago. Nothing more exciting. A small database application based on sqlite3.

After updating 
   from lazarus-2.0.10-fpc-3.2.0-win64
   to     Lazarus-2.0.12-fpc-3.2.0-win64
after startup (F9) I get this error message:   

--- Quote ---Debugger error.

The debugger crashed with status
Save your work now!

Press "Stop" and hope for a fix for this error.

The debugger could not run the application.
This may be caused by missing debug info.
--- End quote ---

When I downgrade my system back to lazarus-2.0.10-fpc-3.2.0-win64 all is well again.

Is this a bug in this newer version? Or is there a parameter to be set to solve this problem?

Thank you for your help.


The GDB version was changed between the 2 releases.
The Problem: Both versions have problem, just each has a different set of issues.

So Install the latest version, and download gdb 8.2 from
The link is for 64bit IDE.  (The 32bit IDE was not changed)

Note the 8.3.1 and 9.2 version can be tried, but they may not fully work with current Lazarus versions (they will/should with 2.2 once that is out).

If changing gdb version does not fix it, I will need more details on the error.

On Windows and Linux you can also use FpDebug

В настройках поменяйте отладчик gdb. Там указан путь к 32-х битной версии отладчика, а нужен 64-х битный. Если нет 64-х битной версии, скачайте её, и сделайте как указал Мартин.

Google translate:
Change the gdb debugger in the settings. The path to the 32-bit version of the debugger is indicated there, but the 64-bit one is needed. If there is no 64-bit version, download it and follow Martin's instructions.


Thank you for the detailed support. I'll give it a try as soon as I can and let you know about the results.

Regards and happy Easter holidays

Hallo, everybody.


Acording to your hints I did the following:

1. I downloaded gdb8.3.1
2. Copied cygwin1.dll to c:\windows\system32
3. Replaced G:\lazarus.prog\mingw\x86_64-win64\bin\gdb.exe with the downloaded version
4. Left the downloaded gdbserver.exe untouched because I didn't find an equivalent on my system.

Pitifully that didn't change anything. The error message remains the same.

Then I started lazarus.exe with the following parameters:


--- End code ---

The resulting Logfile ist attached to this message. Thanx for your help. I appreciate it very much.

You wrote "Change the gdb debugger in the settings." What do you mean exactly? In Lazarus parameters I did not see how to change between 32 and 64 bit. The starting parameter is.




[0] Message Index

[#] Next page

Go to full version