Recent

Author Topic: My component Palette is above all of the window [Solved]  (Read 733 times)

Gald

  • New Member
  • *
  • Posts: 48
My component Palette is above all of the window [Solved]
« on: April 01, 2021, 08:51:07 am »
When i was trying to custom the IDE layout, i accidentally  :-[  make this and i have no idea to turn it back.
Please, help me!

See pics:
« Last Edit: April 02, 2021, 02:50:46 am by Gald »

wp

  • Hero Member
  • *****
  • Posts: 8368
Re: My component Palette is above all of the window
« Reply #1 on: April 01, 2021, 10:51:39 am »
I don't know what you did, but there are some "Restore defaults" commands in the IDE configuration dialogs.

If you undocked the component palette from the CoolBar (but I don't know if this is possible at all...) you could try "Tools" > "Options" > "Environment" > "IDE Coolbar" > "Restore defaults".

In the same dialog there is also page "Environment" > "Component palette" with another "Restore defaults" - but I think this refers to the arrangement of the palette pages and icons.

The next one will probably fix the issue, but destroy your other settings: Go to "View" > "IDE Internals" > "About IDE". In line "Primary config directory" find out in which directory the IDE stores your settings. Close Lazarus, rename this config folder (so that you can return to the current settings), restart the IDE --> default settings will be created in which the component palette should be correct again. You must manually restore your other settings, and you must re-install your extra components afterwards, however.
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

Gald

  • New Member
  • *
  • Posts: 48
Re: My component Palette is above all of the window
« Reply #2 on: April 01, 2021, 11:01:01 am »
Ow Thanks!

I'll do it. Restore buttons didn't work, I already tried, but it not applies to Component Palette.

nummer8

  • Jr. Member
  • **
  • Posts: 74
Re: My component Palette is above all of the window
« Reply #3 on: April 01, 2021, 11:21:56 am »
It looks like you maximized your component palette form. Please try to use the form buttons to unmaximize the form. Or use the mouse to adjust the form height

GetMem

  • Hero Member
  • *****
  • Posts: 3355
Re: My component Palette is above all of the window
« Reply #4 on: April 01, 2021, 01:19:55 pm »
@Gald
Please do the following:
1. Download attached zip file, extract archive
2. Go to Menu->Tools->Desktop->Import
3. Import extracted IDE_Layout.xml
4. Make sure the "Default docked" is the active desktop(it should be by default)
5. Close the Desktop dialog
6. Restart IDE

Every time you make some changes to the desktop, always export it. It's much easier to restore at a later time.

Ps: I assume that anchordocking_dsgn is installed.

Gald

  • New Member
  • *
  • Posts: 48
Re: My component Palette is above all of the window
« Reply #5 on: April 02, 2021, 02:50:06 am »
nummer8:
I tried everything, but thanks!

GetMen:
Look how crazy it becomes on the pic.
Very sad i cannot reproduce this, so i can't report it.

wp:
Nice to know that, Lazarus is back and working!

 

TinyPortal © 2005-2018