Forum > FPC development

Freepascal 3.0.4 port to Haiku 64bit

<< < (2/4) > >>

Begasus:
Hello, at the moment Haiku has both 32bit and 64bit (FPC 3.2.2) packages (and FPC_source) package available that can be installed through our packagemanager.
I've been playing around a bit with it, also added a package for libQt5Pas (1.2.9) for Haiku.

I am able to build Lazarus on both arch's and on 64bit it launches fine, on 32bit it fails to launch as it can't find libstdc++.r4.so (which is gcc2*), I suspect that the 32bit package somehow links to it? I've build it with gcc8* compiler so can't figure out why it still insist on using the mentioned library

jma_sp:
Thanks Begasus.
I have tried to compile Lazarus under Haiku in 64 bit mode with fpc 3.2.0 and latest trunk Lazarus sources. It finalize with errors.
I compiled with make bigide LCL_PLATTFORM=qt5
It compile most of the source code  but not all.
So compile before  qt5 cbindings qmake -- make -- make install fails because destination directory is write protected so i copied it manually to nonpackaged -- lib
Actual qt5pas is for qt 5.6.1 Haiku Qt version 5.15 and have available qt 6 base in its depot.
It is a pitty that bepascal/befpc was discontinued and not have a Haiku native widgetset with Lazarus.
Fpcupdeluxe fail to install both freepascal and lazarus, i have tried with stable, trunk,....
In the other hand freepascal install ok  in 64 bits but when moving mouse in fp ide it send strange code to screen edition as it where typed by keyboard.

Begasus:
Has been a while since I last checked, I have a script to make the build complete, haven't checked a Qt6 build for either lazarus/libQt5(?).pas if it works, would be nice if the build for fpc could be provided as a build against gcc11 for Haiku ...

DonAlfredo:
I have tweaked fpcupdeluxe to solve some issues on Haiku i386 and x86_64.
See screenshot of Lazarus on i386.
This new version will be released soon.

Begasus:
Great work!

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version