Forum > Embedded - ARM

mir toolset not working

<< < (3/4) > >>

petex:
ok, all is well, can compile my existing projects and the pico blinky project. The pico bootloader runs the blinky.uf2 file ok.

I have been using a Raspberry PI to run the openocd remote gdb debugger with the STM32. I now want to use the same configuration with the pico. (I do not have a second pico which looks like the easy option) I cannot find the 2040 configuration for it. Any ideas on how to get this working. (I am upgrading openocd on the PI at the moment-but it takes a long time)

MiR:
https://datasheets.raspberrypi.org/pico/getting-started-with-pico.pdf

has you covered. Google would also been able to tell you so.

petex:
Well, i looked at the docu and re-installed openocd using the recommended script.
Got the debugger working with the pico blinky build with a gdb server on the rpi. Great!!

My original STM32 setup however has been prevented from working. It initially complained about the target speed not set, so i added "adapter speed 1000" to prevent that error but the GDB server doesn't start..... There's also confusion about whether it should be "adapter_khz 1000"

Seems that openocd has been changed and is not backwards compatible. At least i won't need a haircut.




--- Quote ---pen On-Chip Debugger 0.10.0+dev-gf8e14ec-dirty (2021-03-12-18:04)
Licensed under GNU GPL v2
For bug reports, read
   http://openocd.org/doc/doxygen/bugs.html
/usr/local/bin/../share/openocd/scripts/target/swj-dp.tcl:32: Error: Unknown param: 4, try one of: -irlen, -irmask, -ircapture, -enable, -disable, -expected-id, -ignore-version, -dp-id, or -instance-id
in procedure 'script'
at file "embedded:startup.tcl", line 26
at file "openocd.cfg", line 9
in procedure 'swj_newdap' called at file "stm32f1x.cfg", line 46
at file "/usr/local/bin/../share/openocd/scripts/target/swj-dp.tcl", line 32
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Info : BCM2835 GPIO JTAG/SWD bitbang driver
Info : clock speed 1006 kHz
Warn : gdb services need one or more targets defined


--- End quote ---

MiR:
You could try to recompile your old version again and install it in another directory (or use it from the directory where you compiled it)

petex:
luckily i have put the source and compilations in two separate folders.(these took a very long time to do) So at the moment i can re-install the required version with


--- Quote ---sudo make install

--- End quote ---

That doesn't take long. I am not enough of a unix wizard to simplify the job.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version