Forum > Embedded - ARM

mir toolset not working

(1/4) > >>

did a bog standard install of toolset from fcupdeluxe. Get error compiling project1.

--- Quote ---Compile Project, OS: embedded, CPU: arm, Target: C:\fpcupdeluxe-mir\projects\project1.elf: Exit code 1, Errors: 1, Hints: 2
Hint: Start of reading config file C:\fpcupdeluxe-mir\fpc\bin\x86_64-win64\fpc.cfg
Hint: End of reading config file C:\fpcupdeluxe-mir\fpc\bin\x86_64-win64\fpc.cfg
Verbose: Free Pascal Compiler version 3.3.1-r48734 [2021/03/11] for arm
Verbose: Copyright (c) 1993-2021 by Florian Klaempfl and others
Verbose: Target OS: Embedded
Verbose: Compiling C:\fpcupdeluxe-mir\projects\project1.lpr
Verbose: PPU Loading C:\fpcupdeluxe-mir\fpc\units\arm-embedded\system.ppu
Verbose: PPU is compiled for another processor
Fatal: Can't find unit system used by Project1
Verbose: Compilation aborted
Verbose: C:\fpcupdeluxe-mir\fpc\bin\x86_64-win64\ppcrossarm.exe returned an error exitcode

--- End quote ---

install options shown in attached

Just for me to understand:

You tried to compile the empty default project that opens up when you have built & installed a fresh copy of fpcupdeluxe?

Or did you open one of your projects and that one failed?

please provide a copy of the lpi file you used...

i installed a fresh instance of lazarus,fpc and embedded compiler. I then tried to build a working project using the existing compiler i have been using for embedded and I got the error.
I then created a new project, changed the target to embedded with no compiler switches and i got the same error.

Am i using the correct combination in fcup ? I am using the toolset to build STM32 projects and I thought I would keep up with latest changes, especially with the pico.

only setting embedded is not enough you have to tell the system to use arm, subarch and put in a correct -Wp.

Please clone the pico repository and open an lpi provided there and try compile.

Sharing your lpi will make helping you a lot easier, my magic glass spere is a litty cloudy atm, I cannot see what you actually tried to do...

Also it is important to have the correct subarch compiler, please check the doku on the wiki....

What folders did you install the new and old instances into?

You will need to provide more info to get good troubleshooting assistance...


[0] Message Index

[#] Next page

Go to full version