Forum > Windows (32/64)

Cannot compile project since refresh installation

(1/2) > >>

   Hi guys,

   I installed the newest version of Lazarus (lazarus-2.0.12-fpc-3.2.0-win64.exe). Since then I cannot compile the project I am working on. I use Windows 10 64 bit, I installed: lazarus-2.0.12-fpc-3.2.0-win64.exe.

   1. I tried to uninstall/reinstall the Lazarus ,
   2. I tried to 'Recompile IDE to: normal profile' with 'Clean all' option,
   3. I ran Project/Test,
   4. I tried to 'Recimple and build all' settings were: 'LCL widgetset: win32/win64', 'Target OS: win64'
   Always having the same results. I don't have any other idea...

   The error messages are:

"HZSBootloader.lpr(21,1) Error: Undefined symbol: FPC_EMPTYINTF
HZSBootloader.lpr(21,1) Error: Undefined symbol: SYSTEM_::=::\_POS$RAWBYTESTRING$RAWBYTESTRING::=::\INT64
HZSBootloader.lpr(21,1) Error: Undefined symbol: SYSTEM_::=::\_DELETE$RAWBYTESTRING$INT64$INT64
HZSBootloader.lpr(21,1) Error: Undefined symbol: SYSTEM_::=::\_POS$CHAR$RAWBYTESTRING::=::\INT64
HZSBootloader.lpr(21,1) Error: Undefined symbol: SYSUTILS_::=::\_FILEEXISTS$RAWBYTESTRING::=::\BOOLEAN"

  (Sorry for my English, I am from Hungary.)

  Well, I tried one more thing: uninstalled Lazarus and cleaned Registry (by CCleaner free version). After that I installed a former version of Lazarus. (The last one I used before: lazarus-2.0.8-fpc-3.0.4-win64.exe) And it works fine. (I mean: I was able to compile my actual project.)

  After that I installed again the newest version of Lazarus (lazarus-2.0.10-fpc-3.2.0-win64.exe) and I had the complining problem again. There might be some problem with this new installer?

  (Actually I use the 2.0.8 version again.)

I am very sure that it is not the installer which is causing your issues. Laz 2.0.8 had used FPC 3.0.4, but since Laz 2.0.10 is uses the new FPC 3.2.0 which introduced a series of changes. So, you probably ran into one of these changes. Study the changes list (, hopefully something strikes your eyes.

Otherwise you must show your code here.

You must remove the old FPC 3.0.4 installation completely.
The errors hint that your project or Lazarus IDE configuration has paths for the old FPC version.

  Tried... (uninstall, use CCleaner, reinstall) have the same problem.

  But I tried to open and compile another project (one of my former projects) and the compilation worked fine. So I think, I did something wrong during creating this project. So finally I decided to restart the project. I started a new project file and created the contorls and I use the text of the original .pas file. Now it is working fine!

  So, I think I had some problem with my project file, not the installer. Sorry for bothering you, guys!

  Thanks for the help!


[0] Message Index

[#] Next page

Go to full version