Recent

Author Topic: LAMW - Linux Installation failed  (Read 541 times)

Handoko

  • Hero Member
  • *****
  • Posts: 4145
  • My goal: build my own game engine using Lazarus
LAMW - Linux Installation failed
« on: March 01, 2021, 07:45:01 am »
I set a Ubuntu 18.04.5 64-bit virtual machine to test LAMW, but failed. The installation was using LAMW4Linux-installer (https://github.com/DanielOliveiraSouza/LAMW4Linux-installer).

It failed with the message "Unknown Host: dl.google.com ...". I thought maybe just some connection issues,  I rerun the script and this time it can download all the required files without problem.

Unfortunately, the script stopped while compiling the ide_tools. It said "Identifer not found "FpChmod"". See img1.

I started Lazarus and manually compile the LAMW packages and it also failed with the same issue: FpChmod. See img2.

I thought maybe the downloaded LAMW is not the latest version. But I was wrong, the downloaded LAMW source was the latest version. I compared the file Controls.java with the LAMW source on the github. The line #62 import android.app.ActivityManager; can be found on mine too. That line was commited to github on Feb 28, 2021. See img3.

So I'm sure all the required files are downloaded properly and the LAMW on the virtual machine was the latest version.

Does anyone has problem running/installing LAMW on Linux? Or maybe LAMW cannot to be compiled on Ubuntu 18.04?

GetMem

  • Hero Member
  • *****
  • Posts: 3978
Re: LAMW - Linux Installation failed
« Reply #1 on: March 01, 2021, 08:01:56 am »
@Handoko
I will run a few tests on my Linux Mint 19.2 virtual machine and report back.

af0815

  • Hero Member
  • *****
  • Posts: 656
Re: LAMW - Linux Installation failed
« Reply #2 on: March 01, 2021, 08:14:42 am »
On Linux actual 2 issues known by me. One unit was not in the uses clause and a renaming issue was also found, ONLY Linux. i have corrected the issues and the installing was ok.  This is no issue by opm, it is in lamw itself, because the installer lamw4linux-installer use the newest sources.
« Last Edit: March 01, 2021, 08:16:45 am by af0815 »
regards
Andreas

GetMem

  • Hero Member
  • *****
  • Posts: 3978
Re: LAMW - Linux Installation failed
« Reply #3 on: March 01, 2021, 08:37:31 am »
I have the same "Identifier not found FpChmod" error. In my opinion, we should report this bug.

Handoko

  • Hero Member
  • *****
  • Posts: 4145
  • My goal: build my own game engine using Lazarus
Re: LAMW - Linux Installation failed
« Reply #4 on: March 01, 2021, 09:01:53 am »
I have the same "Identifier not found FpChmod" error. In my opinion, we should report this bug.

Thank you for testing it. I know the developer of LAMW checks the forum regularly, let's wait his reply.

On Linux actual 2 issues known by me.

Please share the issues so it can be fixed on next release.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1431
Re: LAMW - Linux Installation failed
« Reply #5 on: March 01, 2021, 10:04:17 am »
I have fixed the Linux issues in LAMW.
To enjoy these fixes, you need to use the GitHub sources. The OPM sources/zip lag behind.
https://github.com/jmpessoa/lazandroidmodulewizard/

Handoko

  • Hero Member
  • *****
  • Posts: 4145
  • My goal: build my own game engine using Lazarus
Re: LAMW - Linux Installation failed
« Reply #6 on: March 01, 2021, 04:53:21 pm »
Thank you for the fixes.

I think it solves the installation problem. But now I have 2 issues. A non critical cosmetic issue, see the red circles on the attached image below. And a fail-to-compile issue.

I opened the .../LAMW/lazandroidmodulewizard/demos/GUI/AppDemo1 and compiled the project without changing any settings. But I got a compile-time error "Fatal: Cannot find system used by controls. Make sure all ppu files of a package are in its output directory."

 

TinyPortal © 2005-2018