Recent

Author Topic: [Solved] Problems installing ver lazarus-2.0.12-fpc-3.2.0-win32  (Read 1088 times)

MortenB

  • Jr. Member
  • **
  • Posts: 59
[Solved] Problems installing ver lazarus-2.0.12-fpc-3.2.0-win32
« on: February 28, 2021, 01:59:03 pm »
I have been trying to install this at least 10 times now. No real success.
To make the long story short:
I have uninstalled everything.
I have deleted FPC as well.
I have deleted config files in the $/appdata/local folder.
I have manually checked that ALL folders where I have had Lazarus in have been deleted.
I try to make a fresh install
I have also tried to make a secondary installation.
I Always get this message to begin with:
"Directory: C:\lazarus\fpc\2.6.4\source\

Error: directory not found
You can download FPC and the FPC sources from http://sourceforge.net/projects/lazarus/?source=directory"

I can redirect this to: C:\lazarus\fpc\3.2.0\source
And everything seems good until I open the IDE and try to compile something.

The easiest is just to run a blank form, which instantly provides me with the error message: project1.lpr(9,3) Fatal: Can't find unit Interfaces used by Project1
---
Ok. I then update the unit path in Project Options.
The IDE actually tells me where the Interfaces unit is:
 
unit
 Interfaces

C:\lazarus\lcl\interfaces\win32\interfaces.pp(19,6)

Package

LCL
, so I just add this location to Other Unit Files: C:\lazarus\lcl\interfaces\win32\

And on next compile: I get:
Messages, Warnings: 1
Warning: other unit files search path (aka unit path) of "project1" contains "C:\lazarus\lcl\interfaces\win32", which belongs to package "LCL"
Compile Project, Target: C:\Users\Morten\AppData\Local\Temp\project1.exe: Exit code 1, Errors: 1
interfaces.pp(29,3) Fatal: Cannot find InterfaceBase used by Interfaces, incompatible ppu=C:\lazarus\lcl\units\i386-win32\interfacebase.ppu, package LCLBase
...
and I am lost.

I don't know how to resolve this :(
A fresh install does not change the outcome.
A separate installation does not change the outcome.

Any ideas?
« Last Edit: February 28, 2021, 04:15:16 pm by MortenB »

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 7098
  • Debugger - SynEdit - and more
    • wiki
Re: Problems installing ver lazarus-2.0.12-fpc-3.2.0-win32
« Reply #1 on: February 28, 2021, 02:23:42 pm »
Quote
I Always get this message to begin with:
"Directory: C:\lazarus\fpc\2.6.4\source\
You get that error when you start the IDE, or while the installer runs?
The answers below are all assuming when you start the IDE.

If "while the installer runs" => check your environment setting PATH => somewhere in there might be an entry pointing to an old fpc install, anywhere on your system.



As do many Windows Applications, Lazarus keeps the user settings when you uninstall it.
They are usually in C:\Users\USERNAME\AppData\Local\lazarus

But you seem to have found them, as you said you deleted them.....

Just in case, when you make a new install, the installer has a checkbox to clear them.
However normally you should not need that checkbox (and if you do, back it up, you can safely restore at least EditorOptions.xml, and some others but I would need to check and find out which ones)


I am a bit puzzled by your description. Lazarus really only looks in 2 places.

The directory in which it is started (the install directory)
The "primary-config-path" => that is C:\Users\USERNAME\AppData\Local\lazarus (unless you give it on the commandline, or have it configured in <install_path>/lazarus.cfg

Both of them you deleted.

There is no registry (not for lazarus / the inno installer creates registry, for associating file locations, and for where the uninstaller is / but none of them are accessed when running lazarus/fpc)


In case you start your Lazarus via a link on the desktop or startmenu, make sure they do not point to some old forgotten installation.

You can open the folder you installed to (e.g. c:\lazarus) and run lazarus.exe directly from that folder.
(Yes for that test you can skip startlazarus)

If that test goes ok, you can test with startlazarus.exe.



You should not need to download fpc separately it is included.

So here are some steps to test, to check your intstall.

After you installed (and make sure your downloaded installer does not contain the word "cross")
You should have (just a selection, there are more) / * can either be i386-win32 or x86_64-win64
c:\lazarus
c:\lazarus\ide
c:\lazarus\mingw\*\gdb.exe
c:\lazarus\fpc\3.2.0\bin\*\fpc.exe
c:\lazarus\fpc\3.2.0\bin\*\fpc.cfg  <<< important

If you open fpc.cfg it contains some file/dir locations, they should all be in c:\lazarus\fpc\.....




MortenB

  • Jr. Member
  • **
  • Posts: 59
Re: Problems installing ver lazarus-2.0.12-fpc-3.2.0-win32
« Reply #2 on: February 28, 2021, 04:13:26 pm »
I did another rush of uninstalls on my computer.
Found some old Delphistuff that I don't use anyway. This was uninstalled and deleted whatever was left.
I cleaned up the environment variables and deleted anything and everything related to FPC and Delphi.
Uninstalled and Deleted remainders in the Lazarus folder.
Deleted the config file in the Appdata/.../Lazarus folder.

Restarted computer
Crossed my fingers
... and toes

Installed Lazarus like before.
Worked like a charm!

When starting the IDE, no error messages!
It now compiles, no error messages.

I cannot pinpoint exactly what did the trick, but I do not think it all was about FPC environment path value... but then again, it could have been that easy :)

I did only get the error when I started the IDE. The installer worked flawlessly all and every time.
Anyway. Thank you for giving the list.
I did go a bit further, but I simply love Lazarus :D No need for Delphi then :D

Thank you again!

 

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 7098
  • Debugger - SynEdit - and more
    • wiki
Re: [Solved] Problems installing ver lazarus-2.0.12-fpc-3.2.0-win32
« Reply #3 on: February 28, 2021, 04:34:44 pm »
Having Delphi and FPC both installed sometimes give an error, when Delphi is in path, and the "make.exe" from Delphi is used.
But that would be a diff error. That could not point to any 2.6.4 fpc (which is rather old).

Or maybe, I don't know... I heard at some point Delphi shipped fpc, as cross compiler to Mac. (Hearsay, no idea). If so, and if that was 2.6.4, and if ..... ?

 

TinyPortal © 2005-2018