Forum > Third party

HTTP/2+HTTP/1.1+WebSocket server with Free Pascal

<< < (4/5) > >>

senglit:
hi,

when I tried to install it I got a error:oglregexprwrapper.pas(17,3) Fatal: Cannot find regexpr_t used by OGLRegExprWrapper of package commonutils_ilya2ik.

noszone:
Is your component fully supporting all major operaions? I mean is it safe to use it in live production project?

iLya2IK:

--- Quote from: senglit on January 13, 2022, 10:05:11 am ---hi,

when I tried to install it I got a error:oglregexprwrapper.pas(17,3) Fatal: Cannot find regexpr_t used by OGLRegExprWrapper of package commonutils_ilya2ik.

--- End quote ---

Hello.
The problem is caused by the fact that the current version of Lazarus uses an outdated RegExpr module. If your version of Lazarus already has REVersionMajor >= 1 in the RegExpr module, then it is correct to change two lines in module OGLRegExprWrapper:


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---{.$define regexpr_new}{$define regexpr_t}
to


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---{$define regexpr_new}{.$define regexpr_t}
Otherwise, it is strongly recommended to add all files from the folder "src" from repository https://github.com/andgineer/TRegExpr to the project folder or to the commonutils folder, and then rename regexpr.pas to regexpr_t.pas

If you do not want to download a new version of TRegExpr, you can limit yourself to the following change in OGLRegExprWrapper module

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---{.$define regexpr_new}{.$define regexpr_t}

iLya2IK:

--- Quote from: noszone on January 13, 2022, 11:25:15 am ---Is your component fully supporting all major operaions? I mean is it safe to use it in live production project?

--- End quote ---

This product is just a convenient tool for realizing your specific needs - banking, shopping, streaming, etc. This server by itself cannot guarantee the security of transactions within your or any other external software - this product was not developed for this purpose. The business logic of such a live production project must be programmed by you yourself by, for example, connecting to a database management system with data replication, etc. Whereas WCHTTPServer will provide a platform and interface for your business logic to interact with the web. This product was developed by me for myself - to calculate engineering and scientific problems on a remote server. The server copes with this task regularly. Of course, it does not provide such a volume of features and a set of tools as many (non)commercial products, but in return it provides deep integration with the free pascal/lazarus development environment, reasonable query processing speed and ease of deployment on server hardware.

senglit:
It works! thank you!


--- Quote from: iLya2IK on January 14, 2022, 01:11:00 pm ---
--- Quote from: senglit on January 13, 2022, 10:05:11 am ---hi,

when I tried to install it I got a error:oglregexprwrapper.pas(17,3) Fatal: Cannot find regexpr_t used by OGLRegExprWrapper of package commonutils_ilya2ik.

--- End quote ---

Hello.
The problem is caused by the fact that the current version of Lazarus uses an outdated RegExpr module. If your version of Lazarus already has REVersionMajor >= 1 in the RegExpr module, then it is correct to change two lines in module OGLRegExprWrapper:


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---{.$define regexpr_new}{$define regexpr_t}
to


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---{$define regexpr_new}{.$define regexpr_t}
Otherwise, it is strongly recommended to add all files from the folder "src" from repository https://github.com/andgineer/TRegExpr to the project folder or to the commonutils folder, and then rename regexpr.pas to regexpr_t.pas

If you do not want to download a new version of TRegExpr, you can limit yourself to the following change in OGLRegExprWrapper module

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---{.$define regexpr_new}{.$define regexpr_t}
--- End quote ---

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version