Forum > Lazarus

Lazarus Release 2.0.12

<< < (4/10) > >>

I did not have to reinstall FPC, it worked fine.

Igor Kokarev:
Thanks for all your hard work on Lazarus!

Thanks for the release!


--- Quote from: geraldholdsworth on February 25, 2021, 07:56:13 pm ---So excited, I downloaded and installed it for my Mac (High Sierra), which it upgraded itself from Lazarus 2.0.11, ran my project and got told:
"cocoagdiobjects.pas(11,34) Fatal: Can't find unit CocoaGDIObjects used by CocoaPrivate"

Not a great start.

EDIT: Followed the instructions to completely remove Lazarus, then started again. Same error. Gone back to 2.0.11, which works fine.

--- End quote ---
Isn't 2.0.11 the branch from where 2.0.12 was built?
They should be identical now.


--- Quote from: Bloodbat on February 26, 2021, 12:54:12 am ---I have two problems with the Win32 version:
-The first is extremely annoying; but not a deal breaker: the Source Editor is quite sluggish, 2.0.10 wasn't when editing the same code base.
-It tends to hang when closing: when I first installed it and rebuilt it to install packages it refused to close until I forced it via Windows, and has refused every time I tried to get it to rebuild without hanging: I have to force it through Windows or Task Manager. It builds properly: the hang occurs when the IDE is closing itself to restart. The problem is also present, intermittently, when building any of my own code, those unlucky times when I close it the window goes away, but I can see the process wasting CPU cycles until I kill it with Task Manager or similar.

--- End quote ---
You can see the merged revisions here :
It is unlikely that any of those caused a big slowdown or hang. Such things have happened for unknown reasons also in the past.
I recommend you try Lazarus trunk. It is much ahead of fixes_2.0.x branch now. It also has some speed optimizations.
Soon a branch for 2.2 will be forked from it.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version