Recent

Author Topic: [LAMW] Error installing last version of LAMW  (Read 1213 times)

juank1971

  • Full Member
  • ***
  • Posts: 112
[LAMW] Error installing last version of LAMW
« on: January 31, 2021, 11:37:33 pm »
I'm trying to install the latest version of LAMW and it gives me the following error: I use lazarus 2.1

juank1971

  • Full Member
  • ***
  • Posts: 112
Re: [LAMW] Error installing last version of LAMW
« Reply #1 on: January 31, 2021, 11:38:45 pm »
i uninstalled the lazarus completely and reinstalled them and it gives me the same error

jmpessoa

  • Hero Member
  • *****
  • Posts: 1870
Re: [LAMW] Error installing last version of LAMW
« Reply #2 on: February 01, 2021, 02:17:31 am »
Ok.

The issue is in "LamwDesigner.pas"  [....\android_wizard] line 64 ....

[we change it to be compatible com lazarus trunk...]

But now you got a bug  using lazarus "2.1"

Please, try find "LazVersion.pas"  [...\components\lazutils]  and put the code here.... 

Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

juank1971

  • Full Member
  • ***
  • Posts: 112
Re: [LAMW] Error installing last version of LAMW
« Reply #3 on: February 01, 2021, 03:06:52 am »
ok this is and thanks jose

jmpessoa

  • Hero Member
  • *****
  • Posts: 1870
Re: [LAMW] Error installing last version of LAMW
« Reply #4 on: February 01, 2021, 03:30:41 am »

In "LamwDesigner.pas"  [....\android_wizard]

Please, change lines  64 and  1976:

OLD:

lcl_fullversion>=2010000

NEW

lcl_fullversion>2010000

And test!
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

juank1971

  • Full Member
  • ***
  • Posts: 112
Re: [LAMW] Error installing last version of LAMW
« Reply #5 on: February 01, 2021, 05:36:17 am »
sorry another error

jmpessoa

  • Hero Member
  • *****
  • Posts: 1870
Re: [LAMW] Error installing last version of LAMW
« Reply #6 on: February 01, 2021, 05:46:28 am »
But now we have a Lazarus issue.... not a LAMW issue....

Try comment the  override
directive  -->   //override
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

juank1971

  • Full Member
  • ***
  • Posts: 112
Re: [LAMW] Error installing last version of LAMW
« Reply #7 on: February 01, 2021, 05:51:23 am »
i tested in lazarus 2.0.10 and installed fine no errors

the problem is in lazarus 2.1

jmpessoa

  • Hero Member
  • *****
  • Posts: 1870
Re: [LAMW] Error installing last version of LAMW
« Reply #8 on: February 01, 2021, 05:56:51 am »
Yes, can you see in "GDBMIDebugger.pas"  ?

Quote
  { TGDBMIDebuggerCommandStartDebugging }

  TGDBMIDebuggerCommandStartDebugging = class(TGDBMIDebuggerCommandStartBase)
  private
    FContinueCommand: TGDBMIDebuggerCommand;
    FSuccess: Boolean;
  protected
    function  DoExecute: Boolean; override;
    function  GdbRunCommand: String; virtual;
    function  DoTargetDownload: boolean; virtual;
  public
    constructor Create(AOwner: TGDBMIDebugger; AContinueCommand: TGDBMIDebuggerCommand);
    destructor Destroy; override;
    function  DebugText: String; override;
    property ContinueCommand: TGDBMIDebuggerCommand read FContinueCommand;
    property Success: Boolean read FSuccess;
  end;

What about 2.1 ??

Edited:

May this work for 2.1

Change "GDBMiServerDebuggerLAMW.pas"  as:
Code: [Select]
function GdbRunCommand: String;  //override;
« Last Edit: February 01, 2021, 06:13:14 am by jmpessoa »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

juank1971

  • Full Member
  • ***
  • Posts: 112
Re: [LAMW] Error installing last version of LAMW
« Reply #9 on: February 01, 2021, 06:13:07 am »
yes worked , install in lazarus 2.1 the last lamw
i see the menu ,    buid release signed apk..

thanks for all jose . good job.

 change
In "LamwDesigner.pas"  [....\android_wizard]

lcl_fullversion>=2010000

for

lcl_fullversion>2010000

And
in C:\LAMW\lazandroidmodulewizard-master\ide_tools\gdbmiserverdebuggerlamw.pas
comment directive  -->   //override
old
function GdbRunCommand: String; override;
new
function GdbRunCommand: String; //override;
« Last Edit: February 01, 2021, 06:26:33 am by juank1971 »

jmpessoa

  • Hero Member
  • *****
  • Posts: 1870
Re: [LAMW] Error installing last version of LAMW
« Reply #10 on: February 01, 2021, 06:39:12 am »

Good!!!

I commited the changes to github!!!

Thank you!!!
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

Seenkao

  • Full Member
  • ***
  • Posts: 168
Re: [LAMW] Error installing last version of LAMW
« Reply #11 on: June 04, 2021, 07:40:58 am »
Добрый день!
У меня и Windows 7 и Linux Debian Cinnamon. Все Lazarus версии 2.1.ххх (не могу утверждать точно). FPC 3.2.1.

Мне, для установки и использования LAMW пришлось вернуть всё обратно, так как выдало ошибку при установке. Это было в Windows. При попытке установить в Linux возникла та же проблема.

Если необходимо, я могу сделать видеозапись действий, которые я буду производить, для восстановления работы пакета.

google translate: Good day!
I have both Windows 7 and Linux Debian Cinnamon. All Lazarus versions are 2.1.xxx (I can't say for sure). FPC 3.2.1.

To install and use LAMW, I had to return everything back, as it gave an error during installation. It was on Windows. I got the same issue when trying to install on Linux.

If necessary, I can make a video recording of the actions that I will take to restore the package.

 

TinyPortal © 2005-2018