Author Topic: [Solved] graphics32 package compilation fails on fresh FPC/Lazarus Linux x64  (Read 2272 times)

Jerome Lioret

  • Newbie
  • Posts: 2

This is my first post and I wonder if I have chosen the right forum channel.

I have the following config on a fresh VirtualBox Debian 10.7 machine:
Lazarus 2.0.10 r63526 FPC 3.2.0 x86_64-linux-gtk2

Trying to compile GR32_Lazarus.lpk ends up with error:

GR32_BlendSSE2.pas(282,23) Error: Generating PIC, but reference is not PIC-safe

The error occurs in an ASM block in function:

Code: Pascal  [Select][+][-]
  1. 207      procedure BlendMems_SSE2(F: TColor32; B: PColor32; Count: Integer); {$IFDEF FPC} assembler; nostackframe; {$ENDIF}

Code block:
Code: Pascal  [Select][+][-]
  1. 279      MOVD      XMM4,ECX
  2. 280      PXOR      XMM3,XMM3
  3. 281      PUNPCKLBW XMM4,XMM3
  4. 282      MOV       RAX,bias_ptr

Did someone already face difficulties to install graphics32 on such a config, or on another, who could help to solve?

Thank you,
« Last Edit: February 01, 2021, 12:38:04 pm by Jerome Lioret »

Jerome Lioret

  • Newbie
  • Posts: 2

I finally managed to install graphics32 using the Online Package Manager.
It is really straightforward.

Marking my own post as solved (if possible :)).

Jerome Lioret


  • Administrator
  • Hero Member
  • *
  • Posts: 9600
  • FPC developer.
On x86_64 globals generally need to addressed indirectly using RIP so if biasptr is the global

lea   rax, rip+biasptr

or so.


TinyPortal © 2005-2018