Recent

Author Topic: [LAMW] error whit Trunk instaling x86 for compile for x86 micro  (Read 243 times)

juank1971

  • Full Member
  • ***
  • Posts: 110
Hi, I'm trying to test LAMW on android 10 but I don't have any device with android 10 and the images I find on the internet for emulators are x86,
So when I try to install x86 with trunk it gives me an error

jmpessoa

  • Hero Member
  • *****
  • Posts: 1785
Re: [LAMW] error whit Trunk instaling x86 for compile for x86 micro
« Reply #1 on: January 28, 2021, 03:29:58 pm »
Quote
Hi, I'm trying to test LAMW on android 10 but I don't have any device with android 10 and the images I find on the internet for emulators are x86,

But, You don't need a LAMW x86 fpc cross-compile to test Android 10....

the "emulator x86 image"  is default for windows system....
« Last Edit: January 28, 2021, 03:36:50 pm by jmpessoa »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

loaded

  • Full Member
  • ***
  • Posts: 172
Re: [LAMW] error whit Trunk instaling x86 for compile for x86 micro
« Reply #2 on: January 28, 2021, 04:55:31 pm »
If you are having emulator problem. My advice;
Clean install Android studio 4.1.2.
Check the emulator installation option during the installation phase.
After the installation is complete, start the emulator (Pixel_3a_API_30_x86) from the virtual devices section. You can close the Android studio.
Then build your Lazarus->LAMW Build Android APK project.
You should see your application in the emulator.
The emulator is faster than almost a real device, also runs x86 and arm based applications smoothly.
https://android-developers.googleblog.com/2020/03/run-arm-apps-on-android-emulator.html
« Last Edit: January 28, 2021, 05:03:39 pm by loaded »
Installing the spelling, google translate is used :)

juank1971

  • Full Member
  • ***
  • Posts: 110
Re: [LAMW] error whit Trunk instaling x86 for compile for x86 micro
« Reply #3 on: January 31, 2021, 11:35:31 pm »
ok tanks all

 

TinyPortal © 2005-2018