Recent

Author Topic: QT 6?  (Read 5854 times)

El Salvador

  • Full Member
  • ***
  • Posts: 107
Re: QT 6?
« Reply #30 on: November 14, 2022, 06:17:34 pm »
I'm trying build Lazarus 2.3.0 (rev main-2_3-2831-gbff5a39d0b) with libqt6pas built by dbannon, but I have these errors:
Quote
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `QWidget::addAction(QIcon const&, QString const&, QObject const*, char const*, Qt::ConnectionType)@Qt_6'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `qt_version_tag@Qt_6.3'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `QWidget::addAction(QString const&)@Qt_6'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `operator>>(QDataStream&, QTextCharFormat&)@Qt_6'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `QPolygon::setPoint(int, int, int)@Qt_6'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `QWidget::addAction(QIcon const&, QString const&)@Qt_6'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `QWidget::addAction(QString const&, QObject const*, char const*, Qt::ConnectionType)@Qt_6'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `operator<<(QDataStream&, QTextCharFormat const&)@Qt_6'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `QPointerEvent::point(long long)@Qt_6'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `QBitmap::~QBitmap()@Qt_6'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `QUrl::fromAce(QByteArray const&, QFlags<QUrl::AceProcessingOption>)@Qt_6'
Warning: linker: /usr/bin/ld: /usr/lib/x86_64-linux-gnu//libQt6Pas.so: undefined reference to `QUrl::toAce(QString const&, QFlags<QUrl::AceProcessingOption>)@Qt_6'


zeljko

  • Hero Member
  • *****
  • Posts: 1381
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: QT 6?
« Reply #31 on: November 14, 2022, 06:24:18 pm »
Have you installed qt6-base-dev ? libQt6Pas should be build against Qt6-6.2.xx, not against 6.3.xx or superior.

El Salvador

  • Full Member
  • ***
  • Posts: 107
Re: QT 6?
« Reply #32 on: November 14, 2022, 06:30:18 pm »
I'm using libqt6pas built by dbannon (from deb package). Downloaded here https://github.com/davidbannon/libqt6pas/releases.

zeljko

  • Hero Member
  • *****
  • Posts: 1381
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: QT 6?
« Reply #33 on: November 14, 2022, 08:16:27 pm »
What version of Qt6 libs is installed on your system ?

El Salvador

  • Full Member
  • ***
  • Posts: 107
Re: QT 6?
« Reply #34 on: November 14, 2022, 08:52:04 pm »
I'm using KDE Neon (base ubuntu 22.04). Qt6 libs are 6.2.4+dfsg-2ubuntu1 (see installed qt6 packages https://pastebin.com/2sb1ep2W ).

zeljko

  • Hero Member
  • *****
  • Posts: 1381
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: QT 6?
« Reply #35 on: November 14, 2022, 08:56:25 pm »
It looks to me that dbannon built libQt6Pas against Qt6 6.3, so that's why it does not work. Hope he'll answer here soon.
This is suspicious in your errors: qt_version_tag@Qt_6.3

dbannon

  • Hero Member
  • *****
  • Posts: 2280
    • tomboy-ng, a rewrite of the classic Tomboy
Re: QT 6?
« Reply #36 on: November 14, 2022, 11:54:02 pm »
Yes, I built libqt6pas against QT6 3.2, I did not realise there were still distros around using 6.2.4. Sorry, I really should have thought about that a bit better.

I will replace it asap, building now as I speak, will be a couple of hours...

Davo
Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

El Salvador

  • Full Member
  • ***
  • Posts: 107
Re: QT 6?
« Reply #37 on: November 15, 2022, 12:06:12 am »
I will replace it asap, building now as I speak, will be a couple of hours...
Thank you so much! As soon as I can, I'll try again.

dbannon

  • Hero Member
  • *****
  • Posts: 2280
    • tomboy-ng, a rewrite of the classic Tomboy
Re: QT 6?
« Reply #38 on: November 15, 2022, 01:00:22 am »
I will replace it asap, building now as I speak, will be a couple of hours...
Thank you so much! As soon as I can, I'll try again.

OK, all libraries updated. (Although the RPMs don't have a new package number, cannot workout how to do that in alien, sigh ...).

Sorry about that.

Davo
Lazarus 2, Linux (and reluctantly Win10, OSX)
My Project - https://github.com/tomboy-notes/tomboy-ng

El Salvador

  • Full Member
  • ***
  • Posts: 107
Re: QT 6?
« Reply #39 on: November 15, 2022, 08:34:10 am »
Good, it works! Thank you!

AlexTP

  • Hero Member
  • *****
  • Posts: 1993
    • UVviewsoft
Re: QT 6?
« Reply #40 on: November 17, 2022, 08:11:10 pm »
Ppl, I added useful info 'Troubleshooting on compiling on Linux' to the Wiki
https://wiki.freepascal.org/Qt6_Interface

zeljko

  • Hero Member
  • *****
  • Posts: 1381
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: QT 6?
« Reply #41 on: November 17, 2022, 08:49:22 pm »
Thanks, actually it should say that it's build against qt 6.2 LTS, since there's no api changes in minor versions, only bugfixes.

zeljko

  • Hero Member
  • *****
  • Posts: 1381
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: QT 6?
« Reply #42 on: November 17, 2022, 08:51:31 pm »
Btw, just tested qt6 on macos, it works like a charm :)

theo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1917
Re: QT 6?
« Reply #43 on: November 19, 2022, 12:24:59 pm »
Quick test on 6.4.0 (OpenSUSE Tumbleweed).

Screenshot here: https://www.lazarusforum.de/viewtopic.php?p=131537#p131537

Thank you!  :-*

 

TinyPortal © 2005-2018