Forum > Windows (32/64)

Win-10 64-bit, installed Lazarus ver 2.0.10. Laz can't find FPC source dir.

(1/2) > >>

The instructions said that by far the easiest way to install Lazarus was to DL and run the proper EXE.  I tried that and allowed it to delete my old Lazarus.  Then it needed new FPC update, so I did that (ver 3.2.0) and let it delete the old FPC.  After it finished, I tried running Lazarus and it says that now it needs the FPC sources from $(LazarusDir)fpc\$(FPCVer)\source.  The comment box says
"Directory: C:\Program_Files\Lazarus\1.8\fpc\3.2.0\source\
"Error: directory not found
"You can download FPC and the FPC sources from
I cannot find any such folder in that location or anywhere else.
All suggestions will be appreciated.  This morning I had a working, albeit old, IDE.  Now I have none!

Peter H:
Some months ago I had a similar case.
Remove all traces of fpc Lazarus and fpc related environment variables and reinstall; this should fix it.

Whenever I install a new Lazarus version I always do this as a "secondary installation" and use a new directory for the Lazarus user settings. This way the new installation can coexist together with the old one, and I always can switch back if something goes wrong.

I think it is the second page of the installer where you can check the "secondary installation" box. Later you are asked about a folder for the config settings - this should be a new directory without any old config files (I name it c:\laz-configs\laz<version>_fpc<version>). Do not register any files with Windows to open on a double-click, because with multiple installations there is a high chance that the registered version will open the wrong IDE.

To fix your current mess, I agree that it is probably the fastest option when you really delete the old Lazarus folder and its config folder (by default it is in c:\users\<your name>\appdata\local\Lazarus), and reinstall a-new.

Thanks Peter H and WP,
* I uninstalled both FPC and Lazarus and manually cleaned up folders and regedit of leftover stuff.
* Reinstalled FPC first, then Lazarus into C: root.  Tried out Compile on blank form and got 5 warnings and about 515 hints.  * Ran and stopped the *.exe w/o errors. 
* Added “Hello World” and it compiled w/o any more warnings or hints and ran w/o any errors.
I think that perhaps they do not run well when installed in a "Program_Files" folder.
I will think about pursuing  that secondary installation idea next time. 
Thanks again. --JohnH


--- Quote from: JohnHerbster on January 18, 2021, 12:35:38 am ---* Reinstalled FPC first, then Lazarus into C: root.
--- End quote ---
This sounds strange. The standard installer for Windows has its own FPC in the package, so there is no need to install FPC separately.

--- Quote from: JohnHerbster on January 18, 2021, 12:35:38 am ---I think that perhaps they do not run well when installed in a "Program_Files" folder.
--- End quote ---
Absolutely true. Never install into "c:\Program files". Access to this folder is restricted.


[0] Message Index

[#] Next page

Go to full version