Recent

Author Topic: Application Not starting - Tablet  (Read 627 times)

mm_coder

  • New Member
  • *
  • Posts: 41
Application Not starting - Tablet
« on: January 11, 2021, 06:09:05 pm »
Created an application with Lazarus.
Program won't run on Tablet
1. Copied entire application folder over - still no go
2. Allowed app thru firewall - no go
3. turned off firewall - no go

App is mostly menu's and odbc.
App runs when moved to other windows 10 pc's
Tablet has i5 vPro cpu

Ideas?

Handoko

  • Hero Member
  • *****
  • Posts: 4070
  • My goal: build my own game engine using Lazarus
Re: Application Not starting - Tablet
« Reply #1 on: January 11, 2021, 06:26:50 pm »
Have you tried to run a 'hello world' program created using Lazarus on the tablet?

It is hard to say what causes your program not able to run on the tablet. But you can try adding items one-by-one and test running it on the tablet. If a simple hello world can run on it then try adding some buttons. Then try to add more items, TEdit, TMemo, a main menu and finally the ODBC connection.

mm_coder

  • New Member
  • *
  • Posts: 41
Re: Application Not starting - Tablet
« Reply #2 on: January 18, 2021, 06:37:41 pm »
I have a simple gui form with buttons that is running on the tablet.

Will update as I go
regards

jamie

  • Hero Member
  • *****
  • Posts: 4189
Re: Application Not starting - Tablet
« Reply #3 on: January 19, 2021, 12:42:21 am »
it has to be a windows TABLET not android etc..

I have a tablet, Laz code runs fine on it.

In any case, if you are missing some support files then it could be a problem or if the Bit size Is wrong also a problem..

if you put a 64 bit app on a 32 bit only Windows Tablet it may not load/start etc.

Also, the tablet may not be hosting the underlayer for 32 bit apps if the tablet is 64 bit.


The only true wisdom is knowing you know nothing

dseligo

  • Jr. Member
  • **
  • Posts: 80
Re: Application Not starting - Tablet
« Reply #4 on: January 19, 2021, 12:54:07 am »
Maybe Windows on a tablet are in S mode.

Do you get any error?

mm_coder

  • New Member
  • *
  • Posts: 41
Re: Application Not starting - Tablet
« Reply #5 on: January 19, 2021, 06:04:54 pm »
Appreciate all the support.

I went to:
Project Forms, selected my form.
The form showed up on my desktop, but was far right.

I dragged the form to the top left region on my development pc. At this point the Left property of the form
displayed 118
Re-Built the app, put it on my tablet, and it's now showing.

Rookie mistake.
On my win32 stuff, when creating windows (CreateWindow), there's a default window location CW_USEDEFAULT.
I figured the location on my screen wouldn't carry into the actual location of the window when the app starts.

Any further comments appreciated. Nice environment




MarkMLl

  • Hero Member
  • *****
  • Posts: 2073
Re: Application Not starting - Tablet
« Reply #6 on: January 19, 2021, 07:18:51 pm »
The form's position property might be relevant here.

https://lazarus-ccr.sourceforge.io/docs/lcl/forms/tposition.html

I'm not entirely confident that all of those work reliably over all graphical environments, so I normally arrange that the form's design-time position is fairly near the top-left and its size slightly smaller than the smallest device I might need for remote-support access.

MarkMLl
Turbo Pascal v1 on CCP/M-86, multitasking with LAN and graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.

 

TinyPortal © 2005-2018