Forum > General

[SOLVED] Re-Compile Lazarus on FreeBSD

(1/4) > >>

Hello Forum,

Sorry, for not being soo often here - I usually use the German Forum. But my question seems to be too special. So, they pointed me here.

My problem: re-compiling the Lazarus IDE on FreeBSD starts but does not seem to come to an end:
 I have installed FreeBSd 12.2 on an old MacBook Pro (8.2) which seems to run OK (the machine is not running MacOS anymore).

I want to use Lazarus on that machine so I installed Lazarus from the packages (latest). Installation went fine, but, when I try to compile the IDE (maybe to add some Lazarus packages; e.g. to get the 1-window-layout of the IDE) the compilation starts quite good. But after some time it looks like it is stopped: no new messages in the message window; title of menu-window shows "... compiling"; no possibility to start new compilation; error message about still running compiliation when shutting down IDE (or machine).

As I am not very familiar with Lazarus in detail (just did the above on Linux and never had that kind of problems), what can I do to fix it? Or, what can I do, to find out, what is going wrong here?

I hope some poeple with (Free)BSD experience are here.

Thank you for your help,


I just tested a new FreeBSD 12.2-RELEASE VM with an installation of Lazarus (GTK2) from the ports collection.

There is one issue, FPC cannot find the linker -- it's looking for /bin/ld.bfd -- solved by soft-linking /usr/local/bin/ld.bfd to /bin. I've logged a bug for this in the BugTracker.

I can rebuild the Lazarus IDE without any issues from Tools > Build Lazarus... (tried a couple of different profiles).

I cannot install any packages from Package > Online Package Manager though - always the same error (see attachment).

Exactly what are you doing?

Hello trev,

thank you for testing and the reply. I have not tried the soft link (I will do as soon as possible) but this sounds as the 1st solution to try out: no linker means no chance for a working executable. But why do I get no message about that - here is the output I get (only the last lines - if more is needed I can post of course):

--- Code: ---....
sparta_fakeformbackground.pas(83,30) Hint: Parameter "AValue" not used
sparta_fakeformbg.pas(20,66) Hint: Unit "sparta_DesignedForm" not used in sparta_FakeFormBG
sparta_reg_smartformeditor.pas(41,51) Warning: Constructing a class "TStarterDesignTimeUtilsManager" with abstract method "GetEDTU"
spartaapi.pas(81,14) Hint: Found abstract method: GetEDTU(<TSTADesignTimeUtilsManager>;LongInt):Class Of TEDTU;
sparta_reg_smartformeditor.pas(20,78) Hint: Unit "sparta_FakeFormBG" not used in sparta_reg_SmartFormEditor
Compile package AnchorDockingDsgn 1.0: Success, Hints: 1
registeranchordocking.pas(179,5) Note: Call to subroutine "procedure TIDEAnchorDockMaster.IncreaseChangeStamp;" marked as inline is not inlined
Compile package sparta_ToolsAPI 0.0: Success
Compile package DateTimeCtrlsDsgn 1.5.1: Success
Compile package fpcunitide 0.1: Success
Compile package EditorMacroScript 0.0: Success
Compile package SQLDBLaz 1.0.2: Success, Hints: 2
sqlstringspropertyeditordlg.pas(167,77) Note: Call to subroutine "operator =(const op1:Variant;const op2:Variant):Boolean;" marked as inline is not inlined
sqlstringspropertyeditordlg.pas(281,77) Note: Call to subroutine "operator =(const op1:Variant;const op2:Variant):Boolean;" marked as inline is not inlined
Compile package SynEditDsgn 1.0: Success
Compile package TurboPowerIProDsgn 0.0: Success
Compile package printers4lazide 0.0: Success
Compile package MemDSLaz 1.2.1: Success
Compile package InstantFPCLaz 1.0: Success
Compile package LazControlDsgn 0.0: Success
Compile package DBFLaz 0.1.1: Success

--- End code ---

it just stops; nothing about linking.

So, thanks for now; I come back after testing with the soft link created.


PS: created the link and I was able to compile (and link and execute) one of my own projects (good). BUT unfortunately, compiling the Lazarus IDE did not work - same as before.

See if you can increase error verbosity,  by turning off filtering by right clicking on a line in the error window. After you do that you must try to recompile

I had the same problem with OPM. As I set the download directory to a visible and accessible one there was no problem with recompiling.


[0] Message Index

[#] Next page

Go to full version