Recent

Author Topic: Missing build-id and hardening-no-pie  (Read 337 times)

flax57

  • New member
  • *
  • Posts: 7
Missing build-id and hardening-no-pie
« on: December 04, 2020, 02:21:43 am »
hi @ll

when i create .rpm or .deb package i get this warning

for rpm :
warning: Missing build-id in /home/brahim/rpmbuild/BUILDROOT/MYAPP-2.1-1.x86_64/usr/bin/MYAPP

for deb : with lintian command  (lintian MYAPP)
W: MYAPP: hardening-no-pie usr/bin/MYAPP

i think build-id is missing on executable file but how to set it ???
ican' t found it on Projects Option !!





MarkMLl

  • Hero Member
  • *****
  • Posts: 1757
Re: Missing build-id and hardening-no-pie
« Reply #1 on: December 04, 2020, 12:55:38 pm »
Is that the build-id inserted by the linker? I routinely have Compiler Options -> Linking -> Options: (-k) with --build-id in the edit box.

However that's for my own use for debugging/support output, and I don't know whether it's the same as you need.

MarkMLl
Turbo Pascal v1 on CCP/M-86, multitasking with LAN and graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.

flax57

  • New member
  • *
  • Posts: 7
Re: Missing build-id and hardening-no-pie
« Reply #2 on: December 16, 2020, 01:42:31 am »
Is that the build-id inserted by the linker? I routinely have Compiler Options -> Linking -> Options: (-k) with --build-id in the edit box.

However that's for my own use for debugging/support output, and I don't know whether it's the same as you need.

MarkMLl

thanks

i have found it here too : http://www.bononiadocta.it/Lazarus/
by adding -k--build-id to /etc/fpc.conf file


 

TinyPortal © 2005-2018