Recent

Author Topic: Catalina to Big Sur?  (Read 1693 times)

RonNash

  • Newbie
  • Posts: 1
Catalina to Big Sur?
« on: December 02, 2020, 09:09:49 am »
I have a 16” MBP that I purchased earlier this year and it is currently running the latest version. What are your thoughts or experiences on installing the new Big Sur OS?

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1350
  • Former Delphi 1-7, 10.2 User
Re: Catalina to Big Sur?
« Reply #1 on: December 02, 2020, 10:29:38 am »
Big Sur has some reported issues (eg monitor connections, bluetooth, wifi) on the new M1 systems though not on my M1 Mac mini base model. I'm not using bluetooth keyboards/trackpads or wifi and my oldish monitor is connected via USB-C to VGA and has no issues.

Backup before upgrading and you can then always restore if you need to do so :)
Lazarus 2.1 r64861 FPC 3.3.1 r49035 macOS 10.14.6 Xcode 11.3.1
Lazarus 2.1 r64891 3.3.1 r49100 macOS 11.2.3 aarch64 Xcode 12.4
Lazarus 2.1 r61574 3.3.1 r42318 FreeBSD 12.1 amd64 VMware VM
Lazarus 2.1 r61574 3.0.4 Ubuntu 20.04 Parallels VM
Lazarus 2.0.10 3.2.0 Win10 Parallels VM

Gizmo

  • Hero Member
  • *****
  • Posts: 750
Re: Catalina to Big Sur?
« Reply #2 on: March 21, 2021, 04:18:19 pm »
Folks

I was using Mojave and Lazarus 2.0.10 fine. Upgraded OSX to Big Sur yesterday and attempted to install v2.0.12. Installation went OK but whenever I try to install a package and rebuild IDE I get errors re the Cocoa widgets.

cocoagdiobjects.pas(12,3) Fatal: Cannot find LCLtype used by CocoaGDIObjects, incompatible ppu=/Applications/Lazarus/lcl/units/x86_64-darwin/lcltype.ppu, package LCLBase

Any ideas here?
Lazarus 2.0.10 and fpc 3.2.0 - Linux Mint 19 LTS, Windows 10 64 and Mac OSX Catalina
Useful Page to remember : http://wiki.freepascal.org/Cross_compiling#From_Linux_x64_to_Linux_i386

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 6992
  • Debugger - SynEdit - and more
    • wiki
Re: Catalina to Big Sur?
« Reply #3 on: March 21, 2021, 06:12:51 pm »
I was using Mojave and Lazarus 2.0.10 fine. Upgraded OSX to Big Sur yesterday and attempted to install v2.0.12. Installation went OK but whenever I try to install a package and rebuild IDE I get errors re the Cocoa widgets.

cocoagdiobjects.pas(12,3) Fatal: Cannot find LCLtype used by CocoaGDIObjects, incompatible ppu=/Applications/Lazarus/lcl/units/x86_64-darwin/lcltype.ppu, package LCLBase

Any ideas here?

Menu: Tools > Configure Build Lazarus
Find and check "Clean all"
"Build"

Should only be needed once.

Gizmo

  • Hero Member
  • *****
  • Posts: 750
Re: Catalina to Big Sur?
« Reply #4 on: March 22, 2021, 08:23:21 pm »
Thanks man...I had already tried that without success. But, having tried to do it again, and having Googled it some more, I realised I needed to update XCode, and re-install the XCode command line tools via the terminal (as instructed in the "Before you begin" part of fpc-3.2.0.intel-macosx.dmg) which makes sense as I had jumped up two versions of OSX. Then when I did the Clean All and Build in Lazarus, the Linkin error no longer occurred. 
Lazarus 2.0.10 and fpc 3.2.0 - Linux Mint 19 LTS, Windows 10 64 and Mac OSX Catalina
Useful Page to remember : http://wiki.freepascal.org/Cross_compiling#From_Linux_x64_to_Linux_i386

 

TinyPortal © 2005-2018