Recent

Author Topic: (Solved)Listbox to array error  (Read 1476 times)

lucamar

  • Hero Member
  • *****
  • Posts: 3454
Re: Listbox to array error
« Reply #30 on: November 29, 2020, 09:25:39 pm »
It compiles OK here. Some normal hints and warnings but compilation ends as it should. Something wrong in your install, then?
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus/FPC 2.0.8/3.0.4 & 2.0.10/3.2.0 - 32/64 bits on:
(K|L|X)Ubuntu 12..18, Windows XP, 7, 10 and various DOSes.

JLWest

  • Hero Member
  • *****
  • Posts: 989
Re: Listbox to array error
« Reply #31 on: November 29, 2020, 09:32:34 pm »
My install of what FPC, Lazarus?
FPC 3.2.0, Lazarus IDE v2.0.4
 Windows 10 Pro 32-GB
 Intel i7 770K CPU 4.2GHz 32702MB Ram
GeForce GTX 1080 Graphics - 8 Gig
4.1 TB

lucamar

  • Hero Member
  • *****
  • Posts: 3454
Re: Listbox to array error
« Reply #32 on: November 29, 2020, 09:39:16 pm »
My install of what FPC, Lazarus?

Either or both, though I'd suspect FPC; after all, Classes ( from which comes TStrings) is part of the RTL.

Where does it go (if anywhere) if you Ctrl-click "ToStringArray" in the IDE?

Not that it should matter much: if it's capable of dealing with TListBox.Items it should be able to access its methods too. It's profoundly baffling...
« Last Edit: November 29, 2020, 09:43:34 pm by lucamar »
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus/FPC 2.0.8/3.0.4 & 2.0.10/3.2.0 - 32/64 bits on:
(K|L|X)Ubuntu 12..18, Windows XP, 7, 10 and various DOSes.

JLWest

  • Hero Member
  • *****
  • Posts: 989
Re: Listbox to array error
« Reply #33 on: November 29, 2020, 09:53:45 pm »
I go over to sourceforge and try to download FPC but the only thing I get is the 32 bit compiler and I have the 64 bit.

FPC 3.2.0, Lazarus IDE v2.0.4
 Windows 10 Pro 32-GB
 Intel i7 770K CPU 4.2GHz 32702MB Ram
GeForce GTX 1080 Graphics - 8 Gig
4.1 TB

lucamar

  • Hero Member
  • *****
  • Posts: 3454
Re: Listbox to array error
« Reply #34 on: November 29, 2020, 10:09:20 pm »
It's best if you just uninstall and reinstall the whole Lazarus; that will get you a "refreshed" install of both, Lazarus and FPC.

While you're at it make sure to get the latest Lazarus 2.0.10. It might be that there was some bug in the version you're using which was corrected later. Or maybe ToStringArray() is new in 3.2.0, I don't know ...
« Last Edit: November 29, 2020, 10:12:43 pm by lucamar »
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus/FPC 2.0.8/3.0.4 & 2.0.10/3.2.0 - 32/64 bits on:
(K|L|X)Ubuntu 12..18, Windows XP, 7, 10 and various DOSes.

JLWest

  • Hero Member
  • *****
  • Posts: 989
Re: Listbox to array error
« Reply #35 on: November 29, 2020, 10:22:01 pm »
I Deleted the FPC dir on the C: drive downloaded and installed FPC 3.2.0. Same error.

I really hate to reinstall Lazerur as I have several packages added to the base.

When you compiled did the UI look alright?
FPC 3.2.0, Lazarus IDE v2.0.4
 Windows 10 Pro 32-GB
 Intel i7 770K CPU 4.2GHz 32702MB Ram
GeForce GTX 1080 Graphics - 8 Gig
4.1 TB

lucamar

  • Hero Member
  • *****
  • Posts: 3454
Re: Listbox to array error
« Reply #36 on: November 29, 2020, 10:27:32 pm »
When you compiled did the UI look alright?

A little huge, with very big fonts, and severely displaced for my screen, but yes, it did look alright.
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus/FPC 2.0.8/3.0.4 & 2.0.10/3.2.0 - 32/64 bits on:
(K|L|X)Ubuntu 12..18, Windows XP, 7, 10 and various DOSes.

jamie

  • Hero Member
  • *****
  • Posts: 4052
Re: Listbox to array error
« Reply #37 on: November 29, 2020, 10:28:38 pm »
I suspect you are actually using 3.0.4 compiler some how, maybe your lazaus 2.0.4 which comes with the 3.0.4 and is installed within Lazarus.

this is what you should try...

 install the 2.0.10 version of Lazarus IDE side by side as a secondary IDE. that will install the 3.2.x compiler within that IDE.

 Start it and do a test run of that TostringArray.

Also, you could delete the FPC 3.2.0 you have and just leave alone the IDE install you have and I bet it will still find a compiler, but it will be 3.0.4 instead.

 In Lazarus you can direct the path to use a different compiler instead of the one that comes with it the older 2.0.4 IDE.

 Have you looked at that to see if it is looking at the 3.2.x install ?
The only true wisdom is knowing you know nothing

JLWest

  • Hero Member
  • *****
  • Posts: 989
Re: Listbox to array error
« Reply #38 on: November 29, 2020, 10:45:38 pm »
Yea it did still find a compiler. It located at C:\lazarus\fpc\3.2.0\bin\x86_64-win64.

Which says it's 3.2.0 but I will try and install another Lazarus install.
FPC 3.2.0, Lazarus IDE v2.0.4
 Windows 10 Pro 32-GB
 Intel i7 770K CPU 4.2GHz 32702MB Ram
GeForce GTX 1080 Graphics - 8 Gig
4.1 TB

JLWest

  • Hero Member
  • *****
  • Posts: 989
Re: Listbox to array error
« Reply #39 on: November 29, 2020, 11:14:31 pm »
Deleted everything but the project. Installed Lazarus. It worked. Using the compiler under the Lazarus install.

Thanks One and all.
FPC 3.2.0, Lazarus IDE v2.0.4
 Windows 10 Pro 32-GB
 Intel i7 770K CPU 4.2GHz 32702MB Ram
GeForce GTX 1080 Graphics - 8 Gig
4.1 TB

 

TinyPortal © 2005-2018