Recent

Author Topic: Wind 7 to Wind 10 smtpsend compile error  (Read 686 times)

mm_coder

  • New Member
  • *
  • Posts: 43
Wind 7 to Wind 10 smtpsend compile error
« on: November 20, 2020, 01:36:17 am »
Old machine Windows 7 64 Lazarus ver 1.8.0
New machine Windows 10 64 Lazarus ver 2.0.10


I've read alot of the posts regarding this error.
I tried adding the synapse package, the error goes away but then an openssl init error comes up and I can't solve the problem, so I removed the
Synapse package, so both projects are identical package wise again.

Could this just be an openssl (32/64) version issue?

I've included the path in my OS to point to the lib folder where ssleay32.dll and libeay32.dll are located (32 an indicator here)?

Hoping someone might get me back on track.
Best,
Bret


mm_coder

  • New Member
  • *
  • Posts: 43
Re: Wind 7 to Wind 10 smtpsend compile error
« Reply #1 on: November 20, 2020, 04:13:12 am »
All I've done is move an application from Windows 7 to a new pc with Windows 10

That is the context of my question.

mm_coder

  • New Member
  • *
  • Posts: 43
Re: Wind 7 to Wind 10 smtpsend compile error
« Reply #2 on: November 20, 2020, 04:27:30 am »
  if not IsSSLloaded then
    raise Exception.Create('Unable to initialize OpenSSL library, please check your OpenSSL installation');

Here's where I'm at now. Looks like ssl is not loading

mm_coder

  • New Member
  • *
  • Posts: 43
Re: Wind 7 to Wind 10 smtpsend compile error
« Reply #3 on: November 20, 2020, 04:52:56 am »
Just leave this. I think I figured it out.
Can't stay away from Lazarus this long, I forget everything.

 

TinyPortal © 2005-2018