Recent

Author Topic: Upgrading trunk: "The prefix of the ... installation is required"  (Read 502 times)

MarkMLl

  • Hero Member
  • *****
  • Posts: 1447
Re: Upgrading trunk: "The prefix of the ... installation is required"
« Reply #15 on: November 22, 2020, 09:18:01 am »
I can confirm that there is no problem if the compiler version is rolled back to 3.0.4.
I was unable to reproduce the issue on my Linux VM (fresh checkout of lazarus trunk, fpc 3.2.0).
Bart

In that case one of us is "doing it wrong". I was using a recently-built 3.2.0 (after I realised that my fpc binary was wrong) and had got a fresh Lazarus trunk from svn. There's definitely a problem in there, and even if it's only expressing itself on my system (due to my particular filesystem layout, or my root/user split) the real issue is that there's not enough diagnostics in the output to show what's going wrong and why.

MarkMLl
Turbo Pascal v1 on CCP/M-86, multitasking with LAN and graphics in 128Kb.
Pet hate: people who boast about the size and sophistication of their computer.

 

TinyPortal © 2005-2018