Recent

Author Topic: InternetTools Again  (Read 576 times)

Bazzao

  • Full Member
  • ***
  • Posts: 178
  • Pies are squared.
InternetTools Again
« on: September 30, 2020, 06:12:27 am »
2 years ago, I had to find out how to install internettools.

https://forum.lazarus.freepascal.org/index.php/topic,26046.0.html

Yesterday I upgraded Lazarus, fixed various issues, now Internettools comes up again.

unit1.pas(86,55) Fatal: Cannot find simpleinternet used by Unit1, incompatible ppu=C:\Lazarus\units\internettools\lib\x86_64-win64\simpleinternet.ppu, package internettools

The package is in the installed list, but shows ...
Quote
Filename:  C:\Lazarus\units\internettools\internettools.lpk
Current state: selected for installation, not installed, RunAndDesignTime

Both save buttons are disabled.
Bazza

Lazarus 2.0.10; FPC 3.2.0; SVN Revision 63526; x86_64-win64-win32/win64
Windows 10.

Handoko

  • Hero Member
  • *****
  • Posts: 3902
  • My goal: build my own game engine using Lazarus
Re: InternetTools Again
« Reply #1 on: September 30, 2020, 06:20:56 am »
Similar problem happened on my Lazarus-Linux several times. After OS upgrade and reinstalling Lazarus, some previous installed packages did not work. Because those packages were already there, so I tried to rebuild the IDE, unfortunately Lazarus failed to rebuild.

My solution is manually remove those problem packages, rebuild the IDE and reinstall them back (using Online Package Manager).

So, I think you may be able to fix your issue by rebuilding the IDE. If it fails, try to uninstall those packages. If you cannot uninstall them, you can force it by deleting the files. After that, rebuilt the IDE and reinstall the packages.

This trick works on Linux, it may also work on Windows I believe.

-edit-
Sometimes I remove the config files before reinstall the IDE, to trick it to threat it is as a fresh install. But because I want to keep some config settings, I usually manually remove some lines in the packagefiles.xml.
« Last Edit: September 30, 2020, 06:26:43 am by Handoko »

Bazzao

  • Full Member
  • ***
  • Posts: 178
  • Pies are squared.
Re: InternetTools Again
« Reply #2 on: September 30, 2020, 07:41:02 am »
Deleted internet tools.

Rebuilt IDE.

Downloaded internettools-master

Added package.

 ERROR FLRE

    {$IFDEF USE_FLRE},FLRE{$ENDIF} //FLRE from https://github.com/BeRo1985/flre or https://github.com/benibela/flre/

Downloaded FLRE. No LPK file.

Trying to contact author.



Bazza

Lazarus 2.0.10; FPC 3.2.0; SVN Revision 63526; x86_64-win64-win32/win64
Windows 10.

Handoko

  • Hero Member
  • *****
  • Posts: 3902
  • My goal: build my own game engine using Lazarus
Re: InternetTools Again
« Reply #3 on: September 30, 2020, 08:41:14 am »
I think this is the correct source location:
https://github.com/benibela/internettools

avra

  • Hero Member
  • *****
  • Posts: 2044
    • Additional info
Re: InternetTools Again
« Reply #4 on: October 01, 2020, 02:19:06 pm »
unit1.pas(86,55) Fatal: Cannot find simpleinternet used by Unit1, incompatible ppu=C:\Lazarus\units\internettools\lib\x86_64-win64\simpleinternet.ppu, package internettools

Next time you face incompatible ppu problem you could try to fix it with clean rebuild of the IDE:
https://forum.lazarus.freepascal.org/index.php/topic,46755.msg373317.html#msg373317
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib

Bazzao

  • Full Member
  • ***
  • Posts: 178
  • Pies are squared.
Re: InternetTools Again
« Reply #5 on: October 01, 2020, 11:28:30 pm »
Thanks avra.

My decision before I got your message was to wipe Lazarus and start again.  There are too many errors popping up each time I do something. I won't be able to get started for a few days now.

I'll make a copy of the current files in a zip.

I know to have a copy of fpc.cfg & document my personal changes to that.

If anyone-else has various files that may have been changed please let me know.

I don't blame those who suggested retaining the existing version. I am now a firm believer that Hazardous Lazarus MUST be uninstalled first.

A wise person, me once said "Don't put your projects with the application", and I'm glad I followed his advice.

Non-uninstalling Lazarus before major upgrade can be Hazardous to your health.
Bazza

Lazarus 2.0.10; FPC 3.2.0; SVN Revision 63526; x86_64-win64-win32/win64
Windows 10.

 

TinyPortal © 2005-2018