Recent

Author Topic: OK to Use MacOS Laz IDE 2.0.10 and 2.1 on Same Code?  (Read 268 times)

Dan3468298

  • Full Member
  • ***
  • Posts: 129
OK to Use MacOS Laz IDE 2.0.10 and 2.1 on Same Code?
« on: September 28, 2020, 05:44:32 pm »
Is it OK to use MacOS Laz IDE 2.0.10 and 2.1 on same code?
MacOS 10.15.5/Lazarus 2.0.10 Build 2020-07-07

Thaddy

  • Hero Member
  • *****
  • Posts: 10526
Re: OK to Use MacOS Laz IDE 2.0.10 and 2.1 on Same Code?
« Reply #1 on: September 28, 2020, 06:26:25 pm »
Not on the binary level, probably also not on the sourcecode level in all cases. Why would you want that?

Dan3468298

  • Full Member
  • ***
  • Posts: 129
Re: OK to Use MacOS Laz IDE 2.0.10 and 2.1 on Same Code?
« Reply #2 on: September 28, 2020, 07:50:58 pm »
My Mac Mini has 2.1 from before 2.0.10 was released.   So will have to uninstall that using the uninstall script.   Thanks. 
MacOS 10.15.5/Lazarus 2.0.10 Build 2020-07-07

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1014
  • Former Delphi 1-7, 10.2 User
Re: OK to Use MacOS Laz IDE 2.0.10 and 2.1 on Same Code?
« Reply #3 on: September 29, 2020, 04:15:32 am »
Is it OK to use MacOS Laz IDE 2.0.10 and 2.1 on same code?

Yes, provided that for Lazarus 2.10 you:

* tick Project Options > Miscellaneous - Maximise compatibility of project files (LPI and LPS) I have no problems swapping between the two; and
* specify a different .lazarus directory (eg open ~/lazarus-src/lazarus.app --args "--pcp=~/.laz_trunk").
o Lazarus v2.1.0 r63871, FPC v3.3.1 r47164, macOS 10.14.6 (with sup update), Xcode 11.3.1
o Lazarus v2.1.0 r61574, FPC v3.3.1 r42318, FreeBSD 12.1 amd64 (VMware Fusion VM)
o FPC 3.0.4, FreeBSD 12.2-STABLE r365646 amd64
o Lazarus v2.1.0 r61574, FPC v3.0.4, Ubuntu 20.04 (Parallels VM)

 

TinyPortal © 2005-2018