Recent

Author Topic: connect mysql8.0 error  (Read 354 times)

softchina

  • New member
  • *
  • Posts: 6
connect mysql8.0 error
« on: August 28, 2020, 11:04:33 pm »
I use mysqlconnector5.7 component to connect mysql8.0 server, and I set skiplibaryversioncheck property to true,and the error shows "can't load default mysql libary...", how to solve this problem,thank you!

btw,I can access mysql8 with navicat,and mysql8 runs ok,and also i'm a new user for lazarus,thank you again!

envirnment: windows 10 pro,Mysql 8.0(green version)
« Last Edit: August 29, 2020, 01:44:20 pm by softchina »

Chris_h174

  • New Member
  • *
  • Posts: 13
Re: connect mysql8.0 error
« Reply #1 on: August 31, 2020, 12:12:10 pm »
I use mysqlconnector5.7 component to connect mysql8.0 server, and I set skiplibaryversioncheck property to true,and the error shows "can't load default mysql libary...", how to solve this problem,thank you!

btw,I can access mysql8 with navicat,and mysql8 runs ok,and also i'm a new user for lazarus,thank you again!

envirnment: windows 10 pro,Mysql 8.0(green version)
There is a dll that the client m/c needs to access.  I don't have a Win m/c running to look just now but it's something like mysqllib.dll (does the dialog box say?) [Edited: may be libmysql.dll].  Find it (must be the right version) and put it in your exe folder or better still in your search path.
HTH
Chris
Chris
Lazarus 2.0.2 fpc3.0.4 on OpenSuse Leap 15.1 and Win7_64.

rvk

  • Hero Member
  • *****
  • Posts: 4329
Re: connect mysql8.0 error
« Reply #2 on: August 31, 2020, 12:25:53 pm »
I use mysqlconnector5.7 component to connect mysql8.0 server, and I set skiplibaryversioncheck property to true,and the error shows "can't load default mysql libary...", how to solve this problem,thank you!
What bitness are you using for Lazarus (32 bit or 64 bit)?
What bitness of the mySQL client is installed (32 bit or 64 bit)?


softchina

  • New member
  • *
  • Posts: 6
Re: connect mysql8.0 error
« Reply #3 on: September 01, 2020, 08:06:39 am »
What bitness are you using for Lazarus (32 bit or 64 bit)?                     //lazarus v2.06 64bit
What bitness of the mySQL client is installed (32 bit or 64 bit)?             //mysql server 8.0 64bit

 

TinyPortal © 2005-2018