Recent

Author Topic: MacOS 10.5 + svn = Error while linking  (Read 4304 times)

sw2090

  • Newbie
  • Posts: 3
MacOS 10.5 + svn = Error while linking
« on: March 12, 2008, 01:10:17 pm »
Hi

I got the latest svn of laz and compiled it with carbon interface as described in the lazarus wiki. This worked fine so far and I can start laz and create a project.
Unfortunately every try to compile any project results in the message "error while linking". I found out that this seems to be an issue of the opengl libraries which are installed twice (once with apple's X11 and once native) which seems to confuse ld so much on leopard that it refuses to link on.
I posted this to the german lazarus forums and got the reply that this is already a known issue but no working solution for this. I tried make options on compiling laz from svn source as described in the wiki and i tried adding linker options from the wiki with no different result.
Does anyone at all have a solution for this or does that mean that laz with carbon is currently unuseable on leopard?

cheers
Sebastian

Tombo

  • New Member
  • *
  • Posts: 21
RE: MacOS 10.5 + svn = Error while linking
« Reply #1 on: March 12, 2008, 05:30:25 pm »
Have you tried to add these to linking options:

'-dylib_file'   '/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib'

sw2090

  • Newbie
  • Posts: 3
MacOS 10.5 + svn = Error while linking
« Reply #2 on: March 12, 2008, 05:51:22 pm »
thanx a 1000times! This made it work finally :)

I'll post this into the german lazarus forum to provide them the solution too!

cheers
Sebastian

Jo

  • Jr. Member
  • **
  • Posts: 63
    • http://www.taomedic.com
MacOS 10.5 + svn = Error while linking
« Reply #3 on: March 20, 2008, 07:52:27 pm »
Tombo, I have the same problem. Where do I insert these options, they seem to apear already on my paths and nothing change when I put them in the compiler option, still error while linking.

Jo

  • Jr. Member
  • **
  • Posts: 63
    • http://www.taomedic.com
MacOS 10.5 + svn = Error while linking
« Reply #4 on: March 21, 2008, 04:44:56 pm »
I've restarted the ide and added those linker options and now everything works, exept for the ability to execute the application from withing the ide (i can execute it from finder).
regards.

 

TinyPortal © 2005-2018