Recent

Author Topic: Linux 64bit FireBird Client 2.5.1 required  (Read 225 times)

emilp89

  • Newbie
  • Posts: 1
Linux 64bit FireBird Client 2.5.1 required
« on: August 24, 2020, 04:15:35 pm »
I have an older application that I want to build for 64bit CentOS/Fedore. I've tried building it, but the issue with it is that it requires libfbclient.2.5.1. Now, from what I do remember. I used to copy the 32bit version of libfbclient.2.5.1 to /usr/lib/. And the application would work.

Now, I've tried doing the same for 64bit version. But I cant find the 64bit version of the library. The closest I found is libfbclient.2.5.2, but it wont accept it.

Can you help me with solving this problem? It's been some time since I developed in Lazarus, so my knowledge is very rusty. Thank you

tonyw

  • Full Member
  • ***
  • Posts: 182
    • MWA Software
Re: Linux 64bit FireBird Client 2.5.1 required
« Reply #1 on: August 24, 2020, 05:26:51 pm »
Try creating a softlink from libfbclient.so.2.5.1 to libfbclient.so.2.5.2

i.e.

ln -s /usr/lib/libfbclient.so.2.5.2 /usr/lib/libfbclient.so.2.5.1

You might also want to consider upgrading to 2.5.9 (the latest Firebird 2.5).

The best solution would be to find where your application is explicitly using libfbclient.so.2.5.1 and change it to a more generic libfbclient.so.2. Most Firebird installers will add this as a softlink to the actual client library.

 

TinyPortal © 2005-2018