Forum > Embedded - ARM

Arduino DUE

<< < (4/5) > >>

Mathias:
Thanks to this post I have come a step further: https://github.com/Sloeber/arduino-eclipse-plugin/issues/892

I have now taken version 1.7.0 of bossac, the upload worked right away, even after several attempts.

But unfortunately it still has a very big shortcoming. As soon as I disconnect the DUE from the power supply and reconnect it, the program no longer starts and the LED no longer flashes.
Only when I upload again will it work again.  ::)

And one more thing, uploading is only possible at the programming port.

But at least you can now test at least a few programs on the DUO. ;)

I use the following command to upload:
--- Code: ---xxx/BOSSA-1.7.0/bin/bossac -e -w -v -b Project1.bin -R
--- End code ---

Thanks to this post I have come a step further:

I have now taken version 1.7.0 of bossac, the upload worked right away, even after several attempts.

But unfortunately it still has a very big shortcoming. As soon as I disconnect the DUE from the power supply and reconnect it, the program no longer starts and the LED no longer flashes.
Only when I upload again will it work again.

And one more thing, uploading is only possible at the programming port.

But at least you can now test at least a few programs on the DUO.

I use the following command to upload:

Another thing to note is that the Com port must be reset via DTS, as is the case in the last code.
Whatever else, if you reset the port after uploading, the program will also be stopped, as with the current removal.

MiR:
Version 1.7 has the disadvantage that there is no precompiled x64 version for Mac available.

So if you you look for doing something that benefits everybody then 1.8 is the minimum version.

Mathias:

I did not test the 1.8.  Somehow I overlooked them.  :-X

Mathias:

--- Quote from: MiR on August 09, 2020, 06:18:07 pm ---Version 1.7 has the disadvantage that there is no precompiled x64 version for Mac available.

So if you you look for doing something that benefits everybody then 1.8 is the minimum version.

--- End quote ---
I have tested the 1.8, only an uninclusive error message.


--- Code: ---$ /n4800/DATEN/Programmierung/Lazarus/Tutorials/Embedded/bossac/BOSSA-1.8.0/bin/bossac --port=ttyACM0 -i

SAM-BA operation failed

--- End code ---
With the 1.7, the information from the CPU comes here.

I also observed something. I wrote yesterday. That with the current removal of the DUE, the program no longer starts.
But when I switched on the PC earlier, the LED was blinking.
Let's see if it will be the same next time.

Mathias:

--- Quote ---I also observed something. I wrote yesterday. That with the current removal of the DUE, the program no longer starts.
But when I switched on the PC earlier, the LED was blinking.
Let's see if it will be the same next time.
--- End quote ---

This is understandable. The PC must first be disconnected from the power supply. Just a soft off / on via the power button is of no use.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version