Forum > General

MacOS Install Trunk Branch Alongside of 2.0.10?

<< < (3/4) > >>

Dan3468298:

--- Quote from: DonAlfredo on July 27, 2020, 07:10:39 am ---@Dan346829
We now have (your) proof that GIT can be used.

However.

--- Quote ---Going to install/update Lazarus only with given options.
--- End quote ---
You need to install FPC first to compile Lazarus.

--- End quote ---

OK.  Followed  skalogryz advice not to do that since I have FPC already installed for Laz 2.0.10.

DonAlfredo:
Don't worry about that. The whole install by fpcupdeluxe will be separate from your normal install.


--- Quote ---for ease of use you might want to try fpcupdeluxe. it should get the trunk for you, and should be able to setup Lazarus into a separate directory.
--- End quote ---
I guess his advice should include FPC ....  :)

Dan3468298:
Selected GIT for FPC+Lazarus.   Install ran OK and Laz Trunk start up screen displayed.   But I got an access violation on selecting Start IDE.  I am installing trunk in Applications/LazTrunk.  See attached pics;

Dan3468298:
How can the RTL not be installed if I used fpupdeluxe?   What is the file name for RTL?

Dan3468298:
Can anyone give me a hand?  I would like to get Trunk running to test some bug reports.  I fixed the FPPKGCONFIG.CFG issue by selecting 'File: /Applications/LazTrunk/fpcpkgconfig/fppkg.cfg' for Trunk.   But I still get an Access Error.  Thanks!

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version