Recent

Author Topic: RichMemo doesn't install  (Read 866 times)

Raf20076

  • Full Member
  • ***
  • Posts: 123
RichMemo doesn't install
« on: July 05, 2020, 08:39:47 am »
Hi Guys

I have downloaded lazarus-ccr-svn-r7525 and I wanted to install RichMemo.
After successful compilation I cant install package but only it coud be added to project.

Do you know what happened?

Thanks


Raf20076

  • Full Member
  • ***
  • Posts: 123
Re: RichMemo doesn't install
« Reply #1 on: July 05, 2020, 09:50:59 am »
It seems to me that it couldn't be find richmemopackage.lrs by compiler.  The file richmemopackage.lrs
exists in richmemo folder,. Something has been broken in richmemopackage.lrs file or itself in richmemo component.

TRon

  • Hero Member
  • *****
  • Posts: 536
Re: RichMemo doesn't install
« Reply #2 on: July 05, 2020, 10:27:20 am »
I have downloaded lazarus-ccr-svn-r7525 and I wanted to install RichMemo.
Did you already tried installing the component by using OPM ? https://wiki.freepascal.org/Online_Package_Manager


Raf20076

  • Full Member
  • ***
  • Posts: 123
Re: RichMemo doesn't install
« Reply #3 on: July 05, 2020, 10:46:41 am »
It seems to me that something was broken in RichMemo component. I try to use earler version.
« Last Edit: July 05, 2020, 01:33:27 pm by Raf20076 »

arneolav

  • Full Member
  • ***
  • Posts: 130
    • ElTranslador
Re: RichMemo doesn't install
« Reply #4 on: July 11, 2020, 04:07:05 pm »
 Lazarus Release 2.0.10:
Got error on install Rich memo

unit Win32RichMemoOle;
 TCustomDataViewObject = class(TCustomDataObject, IOleObject, IDataObject, IViewObject)
Compile package sparta_Generics 0.0: Aborted
Compile package richmemopackage 1.0: Exit code 1, Errors: 2
win32richmemoole.pas(60,23) Error: No matching implementation for interface method "SetData(const tagFORMATETC;var TagSTGMEDIUM;LongBool):LongInt; StdCall;" found
win32richmemoole.pas(74,27) Error: No matching implementation for interface method "SetData(const tagFORMATETC;var TagSTGMEDIUM;LongBool):LongInt; StdCall;" found
« Last Edit: July 11, 2020, 04:32:41 pm by arneolav »
Win XP, Win7, Win 10 win64 , Lazarus 2.0.10
Delphi/DevExpress

arneolav

  • Full Member
  • ***
  • Posts: 130
    • ElTranslador
Re: RichMemo doesn't install
« Reply #5 on: July 11, 2020, 04:24:01 pm »
Lazarus Release 2.0.10:
Got error on install Rich memo

Copy files from:
https://sourceforge.net/p/lazarus-ccr/svn/HEAD/tree/components/richmemo/win32/
Does compile with ADD

Can not install package:
Build IDE: Exit code 2, Errors: 1, Warnings: 2
Warning: svn not in path.
Warning: Recompiling chmreader, checksum changed for C:\lazarus\components\sparta\generics\lib\x86_64-win64\generics.collections.ppu
chmreader.pas(80,12) Fatal: Can't find unit chmreader used by ChmLangRef

« Last Edit: July 11, 2020, 04:34:26 pm by arneolav »
Win XP, Win7, Win 10 win64 , Lazarus 2.0.10
Delphi/DevExpress

wp

  • Hero Member
  • *****
  • Posts: 7624
Re: RichMemo doesn't install
« Reply #6 on: July 11, 2020, 05:04:34 pm »
I checked RichMemo with Laz trunk/fpc 3.2.0 and Laz 2.0.10/fpc 3.2.0 and found some issues in the package - I fixed them in the current ccr revision 7537 (I hope the package maintainer does not mind me modifying his work, but I thought it's faster this way).

Please try again with the latest ccr revision. Note that RichMemo has been split into a runtime and designtime package some time ago. The runtime package is "richmemopackage.lpk", the designtime package is in folder "ide" and named "richmemo_design.lpk". You must first load the runtime package, try to compile it - it should work; if not click "More" > "Recompile Clean" in the package editor. Then load the designtime package, try to compile it, too, and finally install it by clicking "Use" > "Install"; confirm to rebuild the IDE:

RichMemo installs correctly for me following these steps (well, ok - tested only Windows, but I don't see a reason why there should be issues on other widgetsets).
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

Raf20076

  • Full Member
  • ***
  • Posts: 123
Re: RichMemo doesn't install
« Reply #7 on: July 12, 2020, 09:11:13 am »
Quote
I checked RichMemo with Laz trunk/fpc 3.2.0 and Laz 2.0.10/fpc 3.2.0 and found some issues in the package - I fixed them in the current ccr revision 7537 (I hope the package maintainer does not mind me modifying his work, but I thought it's faster this way).

Please try again with the latest ccr revision. Note that RichMemo has been split into a runtime and designtime package some time ago. The runtime package is "richmemopackage.lpk", the designtime package is in folder "ide" and named "richmemo_design.lpk". You must first load the runtime package, try to compile it - it should work; if not click "More" > "Recompile Clean" in the package editor. Then load the designtime package, try to compile it, too, and finally install it by clicking "Use" > "Install"; confirm to rebuild the IDE:

RichMemo installs correctly for me following these steps (well, ok - tested only Windows, but I don't see a reason why there should be issues on other widgetsets).

Thanks it works.  :)I didn't know that there is richmemo_design.lpk in ide folder

arneolav

  • Full Member
  • ***
  • Posts: 130
    • ElTranslador
Re: RichMemo doesn't install
« Reply #8 on: July 13, 2020, 08:17:18 pm »
hi!
Downloaded rev. 7537
compile: Runtime package  OK.

Compile Clean: richmemo_design.lpk,  OK.

On Install design.lpk:
Warning: Recompiling chmreader, checksum changed for C:\lazarus\components\sparta\generics\lib\x86_64-win64\generics.collections.ppu
chmreader.pas(80,12) Fatal: Can't find unit chmreader used by ChmLangRef

chmreader.pas does exist here:  C:\Lazarus\fpc\3.2.0\source\packages\chm\src




Win XP, Win7, Win 10 win64 , Lazarus 2.0.10
Delphi/DevExpress

wp

  • Hero Member
  • *****
  • Posts: 7624
Re: RichMemo doesn't install
« Reply #9 on: July 13, 2020, 10:09:07 pm »
chmreader.pas(80,12) Fatal: Can't find unit chmreader used by ChmLangRef
There's another recent thread about this issue. Please search the forum.
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

winni

  • Hero Member
  • *****
  • Posts: 1899
Re: RichMemo doesn't install
« Reply #10 on: July 13, 2020, 10:20:27 pm »

arneolav

  • Full Member
  • ***
  • Posts: 130
    • ElTranslador
Re: RichMemo doesn't install
« Reply #11 on: July 13, 2020, 11:01:13 pm »
JuhaManninen:
This issue is fixed in Lazarus trunk by r62042. There sparta_dockededitorform uses Generics.Collections from FPC libs when available and its own version when compiled with FPC 3.0.x.
The revision had to be left out of Lazarus 2.0.10 release because of merge conflicts.

......
I did uninstall the chmHelpPkg, all seems to work
Win XP, Win7, Win 10 win64 , Lazarus 2.0.10
Delphi/DevExpress

 

TinyPortal © 2005-2018